[SOLVED] Stop particles?

This might seems like a simple thing, but I’ve just started using Particles Emitter objects yesterday, and I couldn’t find what I’m trying to do anywhere.

How can I stop the particles after they’re emitted? I don’t want to delete them. I just want that their emitter force become 0 after 1-2 secs. PS: I tried to reset a scene timer after the particles were emitted and change the maximum and minimum force to 0 after 1 sec, but it didn’t work. So, the particles, since I don’t want them to be deleted, are being pushed outside of the screen.

The effect I’m looking is a ‘blood bath’. Every time I hit someone, about 50 particles are emitted, and I want them to stop 1 sec after they’re emitted (so it seems like blood on the floor). PS2: I’m creating a top-down shooter.

Can anyone help me with this one? Thanks!

Try the flow action…

I tried, but the flow action only relates to the number of particles that are emitted per second, not their velocity.

It seems that I can only control the velocity when the particles are emitted. What I’m trying to do is to control the velocity (set to 0) after the particles are emitted. Is this even possible? I mean, if the particles emitted were objects, I could just stop them with some actions, but I believe they are not.

Indeed, they’re not objects, so the interactions are very limited (inexistent?). :confused:

Thanks anyway. Gonna try to improvise.

Hi, good luck on the workaround!
A suggestion I just thought is, the blood pool will be a sprite with same color as the particles, and it will fade in by opacity, or scale. Since the blood particle is the same color, you can delete it and hopefully it won’t be noticed.

It should also help with performance, maybe?

1 Like

Hi there!
The possibility to stop and start particle emission will be present in the next release.
Better late than never!

Hi Mixen!
I just got into GDevelop product team and I am getting to know the codebase working on “simple” improvements.

According to this issue, the Capacity action was not working so I fixed it 1 week ago.

I also thought that stop and start actions are way more straightforward so I implemented them and I updated this thread to make sure anyone bumping into this issue could see this is a resolved issue.

Let me know if I can improve my ways of doing!