[Solved] Suddenly, it works abnormally on the mobile

It works well on the computer, but it becomes weird when I play on the mobile. TT
When I touched the button, the rotation started. However, on mobile, once out of a few times, the character rotates freely when the game starts.
Characters don’t spin on computers. And it didn’t even spin on mobile a while ago.
What’s wrong with this? TT
It suddenly became like this.TT
What should I do? TT

How are you detecting a button press? Can you provide a screen shot of the events, and include the ones that rotate the characters?


Touch to start operation. Sometimes there’s no reason to spin for no reason.TT
This problem worked fine on computers, and that worked fine on mobile a few weeks ago. TT
What’s the reason? TT :cry:

I’m a tad confused here.

In your first post you talk about touching a button and rotation starting, and sometimes the character rotates freely when the game starts.

In the photos you’ve provided, the actions are changing scenes. There’s nothing about character rotation.

Also, you don’t describe what the events in the photos do - you just say it doesn’t work. You’ll need to explain what it does, and what you expect it to do.

I modified the picture :sweat_smile::sweat_smile:

To confirm then - is there a scene named “home”, with all characters lower case?

What happens if you run it through the debugger, running it using the “Start Network Preview (Preview over WiFi/LAN)”? Does it work then on the mobile?


The rotation issue will be because the mouse is over the button when the scene starts. This is most likely if the issue is only on mobile and not PC. If you touch the screen on a mobile device, the mouse moves to the touch position, and stays there, unless you “Deactivate moving mouse cursor with touches”.

Thanks to you, I knew what the problem was. I set “de/activate moving” to “no” in this scene, but I set it to “yes” in the previous stage selection scene. That’s why the cursor couldn’t move at the part where the scene changed and kept responding to the touch object in that part.
I thought of another way to control the character and deleted “de/activate moving”. So the problem was solved. Thank you for your help. :smile::smile::smile: