(Solved) There is an issue with either the keys, or forces/animations

In this top down game I made, I recently found out you can’t attack (change an animation) and move diagonally down/left. I first thought it was a problem with my events, so I removed the ones that control movement (I use forces to move), and tried it with the top down movement function, and you still couldn’t attack while moving in that direction, nor could you move that way while holding down the attack key during a cooldown. Please fix this, or let me know what I did wrong. I can almost confirm this is a bug, but I could be wrong.
There are no specifics for arrow keys pressed, or what direction you are going in for the attack events
Edit: Here’s a screenshot. This works when trying to move any direction except diagonal left/down (I use top down movement to move btw).

Without screenshots or an example upload no one can help you

1 Like

Hmmm… I quickly mocked up events you have here and can’t reproduce the problem.

There is a chance you are hitting the maximum number of keys your physical keyboard supports at one time.

Try going to www.keyboardchecker.com and pressing all 3 keys at once. If only two keys turn grey while holding down all 3, you have a hardware limitation. Some keyboards have super specific keys which they limit for reasons unknown to me


I just checked and that turned out to be the case. So I guess his was just a false alarm. Thanks for the help.

1 Like