[SOLVED] Trail not playing animation

I’m making a trail for my player, But when it’s supposed to play the animation, only the first frame plays…
Any ideas how I can fix that ?

The code :

Unless you’re changing the player animation, it looks like you’re adding a lot of objects. I’m wondering if the new one is covering the old one.

What is the object that’s being created?

Also, the center inverted check will delete everything if the animation is not jump_left. I’m wondering if you have the same condition to delete if [inverted] jump_right. The new objects might be getting deleted before the animation can play.

Would a particle emitter work in your concept? If not then maybe a timer so you’re not creating objects so often and/or use an opacity tween to fade the objects and set the tween to destroy the object when the tween is done.

There’s also the extension animate shadow clones that might help. (It can clone any object)

Works well with Animate Shadow Clone ! Thanks,
But question, hope you have an answer, I used the recolorize sprite extension, so I applied it to my shadow clone too, but it recolor like when it’s my second jump and then is back to original colors and recolor after etc…

You’re welcome. I’m not very familiar with the “shadow” extension or the recolor.

Oh no problem, imma check it out ! :slight_smile: Thanks again :slight_smile:

I just tested them. Using “recolor” in “the beginning” does nothing because the objects weren’t created yet. I even tried it with the event after the “shadow” action. Nothing.

l tried to the “recolor” without a condition but it must be an intense action or conflict bc it worked but the “draggable” behavior I had on my main object for testing stopped working. IDKW.

I decided to try using an object boolean. If the variable colored of newsprite is false then set to true and recolor. This seems to work. IDK if it fixes everything but when I tested it the “shadow” extension only created the clones once. So, the “recolor” only ran a few times.