[Solved] Why is this happening?

Hello everyone. I am making a game (everyone is doing) and I ran into some problem. I can’t figure out what that is.
I have made a button, not the clicking one but the ones where we step on it and it triggers something in the game like traps, etc. And the action it does is create a new object. Here is a screenshot:

But everything seems fine. But while testing, I found out that after I step on that button, my animation gets stuck on the first frame.

Like if I have a walk animation with looping checked, after stepping on that button, my animation gets triggered but gets stuck on the first frame. What can I do? I even tried to delete this event and rebuild it, but it resulted in being the same. I don’t think I have a problem with my events. What can I do? Why is this even happening :exploding_head: ? Can someone explain this? (sorry if I am being rude :grinning:)

See if there are any events that are pausing the animation. Use the search tool in the event sheet to quickly search it up

1 Like

Thanks to you that I managed to solve the problem.
Although, I couldn’t find the root of this problem, there was a pause animation event:

And I did this:

So, thanks @Midhil for telling me to do so, and now I have the solution to this problem.

You probably do in your animations handling events, could you try screenshotting those?

Edit: nevermind, you have already solved it would last message didn’t load in for me until later for some reason

1 Like