[SOLVED] Yarn Does Not Account for Commands at End of Node

Hey all. Thanks for the help. The issue is quite simple, I have commands at the end of a node that are not running. I have also attached the associated events that I use to run dialogue in my game. It worked perfectly fine 'till now. Thanks in advance for any help.

1 Like

Hi and welcome! :slight_smile:
When you say it worked until now, do you mean that commands at the end of nodes used to work in a previous GDevelop version?
I haven’t noticed any yarn-related changes lately, but I did report a command-related bug a long time ago.

Thanks for the reply! It’s all good, I got it to work after a little tweaking!

For the sake of folks who may run into the issue, can you provide context (and maybe screenshots) on what you tweaked to fix it?

Essentially, I had a command at the end of a node that would change the animation of an object, in my case it was closing the door of a house. Rather than using the command, I just set my events as shown below:

Obviously, you could change the actions to suit your needs, but this worked for me. I’m aware it is not an ideal solution, but it gets the job done I suppose. Sorry for the vagueness of my earlier reply.

1 Like