Some events are getting canceled

For some reason, some “beginning of scene” events (depending on which order i put them in) are getting completely canceled when the game loads up. This completely breaks the game, and I cant seem to fix it.

Can you give an example? I’ve noticed a couple of extensions don’t work on the 1st frame. It seemed like it was a timing issue and they wanted something that wasn’t created yet. I added a tiny wait and it worked. (That’s not a good fix)

The extension used something like the read pixels. I haven’t tested it in awhile. I reported the issue along with another to the creator and they fixed the 2nd issue. IDK if they fixed the at the beginning issue.

I have some play sound on channel stuff, as well as hiding objects, and creating some objects.

Do you have anything specific that can be recreated. Note: sounds need to be preloaded and music needs interaction first. (You might already know that. I’m just saying)

Sometimes things that look like they should work don’t and it could be related to conditions.

Also, are there any errors in the debugger?

Yes. But only because i have some events trying to modify a sound that was supposed to start at the beginning.

1 Like

The best thing to do is post some screenshots of the events so people can confirm if it’s an issue for everyone.

K, I’ll send some pics when I get the time.

Are the At beginning of scene events all in the same event sheet? Or are they in linked external events? Are the events on the main branch of the event sheet, or are they in subevents?

Ok, there might be some in external events(doubt it), but if there are, those seem to be fine. And no, none are sub events

I also made sure all at the beginning of scene stuff were all in one event, minus some that needed condition, but those still work
Also, an event that isn’t an at the beginning of scene event still doesn’t work.

here are the external events.

Which one?

And which beginning of scene events aren’t working? Is it the same ones every time?

Also, my preference is to have one beginning of scene event, and a series of sub events off that one that need to be run when the scene starts up.

And why do you have a trigger once as a condition of the repeat block? It would be better to have a normal event with the trigger once condition, and the repeat as a subevent.

1 Like

The really long one under the power up group. And I will try to keep all the beginning of scene stuff into one event, but if I need conditions I’ll uses sub events. And I’ll fix the trigger once in the repeat box. Weirdly enough, this started happening once I added a couple lights onto the game. A really big one for the sun(so I could have some semi-realistic shadows) which I have one on the scene to start with, and a smaller one that I attempted to spawn in for certain objects at the beginning of the scene.

How is that not working? The only thing I can tell from the actions is the the animation probably doesn’t play as you expect.

Keep in mind, when you set an animation and it is different to what was previously, it will start the new animation.

However, if the animation is changed but is the same as what it was previously, then there’s no change to the animation; it doesn’t start from the beginning again. If this is what you’re trying to achieve, I’d suggest setting the current frame to 0 so the animation restarts.

Ok, so I fixed everything you said, and it still won’t trigger the beginning event. And that long one, if I collide with the power up object, literally nothing happens, buts it’s supposed to freeze the player by deactivating it’s platformer behavior, and spawning in some shape painters for vfx, and then returning the player to normal, but with the ability to dash. Also, something was interfering with the animation, so I made more than one action to change it.

Can you make a second event that just has the collision with power up object with only one action that does something visual, like change the player’s tint to black? Does that work? If it does, add the second condition and see it still works.

If it does, gradually add each action with the visual change last, and see where it breaks. Sorry, it’s a rather laborious way of doing it, but hopefully it will identify what’s going on.

Yeah, Ill try that, and some of the for each object stuff(for spawning in particle effects) broke, which i guess i could place them manually.
Edit 1 minute later: ok, it want working because of the take into account the particle emitter liked to the powerup, which i deleted and it works fine.

1 Like