Start Game Icon

Hi everyone guys!

That’s my first time in this forum.
I have a problem with the icon that is shown on mobile before the game open. Infact i set the game resolution at a value that is very high in order to fit the scene for every device (from phone to tablets) and i added the action “automatically adapt the game resolution” in “always”.
That instruction works just fine for the game’s scene itself but give me problem for the start logo when i play from my phone (which has a lower resolution). So the question is if there is a resizing action also for “non-game” contents like the start game logo (and yes, in the properties i set the game resolution resize mode in “change width to fit the screen or window size”).

Thank you guys!!!

Hi Gemma, for mobile devices, the best approach for now (less complicated solution) when dealing with screen resolutions is to set the game resolution resize mode to “No changes to the game size” and adding an action “Fullscreen : on” to your scenes.

Note that this stretches the canvas of your game. To avoid blurry, pixelated sprite/images, export your sprites/images in high quality.

Hope this helps :slight_smile:

1 Like

Hi! Thanks for the answer! :star_struck: but i think that i can’t do that… :sob:
Infact my game is a horizontal game-based in which i need a precise scale for the height and only a rescal of the width.
That’s why i can’t set the “no changes to the game size” setting, doing that would give me the annoying black bands in devices with a different aspect ratio.

I see, but using this action


With “No Changes to the game Size” option will make your game adapt to different resolutions of any mobile devices, and also, this would remove the black bars from your game screen. But the only problem is the stretching, though it’s not that much of a problem :wink:.
Hope this helps :slight_smile:

Ok i will try this and let you know! The scene is in a resolution which has the measures of a square (i was thinking about ipad resolution) so i need to be sure that a stretch doesn’t make my game too different from the original experience.
Thank you for all the effort you put in helping me!!

My pleasure, have fun developing :smiley:

I think your case has something to do with anti-aliasing. Try disabling it off for your game itself or for the selected asset only.

isn’t that only for smoother sprites? Maybe i don’t even know what i am talking about… Will give it a try too!