Text is not changing

So I am working on a game, back then the text was working fine and all that stuff, and then yesterday I updated the auto text thing and went to bed I woke up working on the game and I accidentally noticed a weird thing while playing game the text didn’t change. Everything else was working except the text, I don’t know how to fix this or what the problem is.

How old is “back then”? Last month, last year?
The behavior of the timer action changed at some point, for instance.

back then as in last year

Hm, probably something changed between GDevelop updates sadly.
What does your text currently look like?
What events do you use to manipulate it?

Everything else works except the “Change the text”. Instead, the text does the scenes text.

You need to create the dialog object first, then assign the value.

Otherwise you’re assigning “HEY!” to an object that doesn’t exist.

1 Like

It’s still not working.

What does that mean?

What does it do? Can you provide a screen shot of the events you now have?

This, the scenes text

And when I created the dialog object first and then assign the value it was still saying this “Dialog here” I even tried different ways and it still didn’t work.

So it does everything else in that sequence like changing their animation?

yes everything works except the text

Do you have a dialog object on the scene in the editor? Is the UI Layer visible?

Well I was going to say, you can’t change the text of the dialogue before you create it but MrMen caught that first. So with that fixed, it must be something else going on too. I dunno you could try deleting that text object and recreating it with a new one. I had something similar with a sprite object once and that fixed it. It’s a long shot though.

As others have pointed out, the order needs changing slightly so that the text box is created before you put text in it. So you need:

The animation of Burtues is “OhNo” | Create object Dialog at position 64;426 (layer: “UI”)
The animation of Burtues is finished | Change the text of Dialog: Set to “HEY!”
Trigger once… etc.

You could try another approach to get the result you need: try having the dialogue box on the scene from the start instead of creating it in an event, even just as an experiment to see if it works. Drag Dialog onto your scene where you want it and on the UI layer. Hide Dialog in an ‘At the beginning of the scene’ event, and show it again in the event you pasted in your comment. Like this:

At the beginning of the scene | Hide Dialog
= = = = = = = = = = = = = = = = = = = = = = = = = = = =
The animation of Burtues is “OhNo” | Show Dialog
The animation of Burtues is finished | Change the text of Dialog: Set to “HEY!”
Trigger once…etc.

I’ve tried that before and it’s still not working, at this point I really don’t know what to do or how to fix this.

Sorry for the bump, but if you’re still having trouble you can try a “Wait x seconds” action before changing the text and see if it works.