Text is smoothed no matter what

I’m developing “retro” game, so I decided to scale things x3 (procedurally, using change resolution action). I’ve turned out smoothing images, so they’re crisp and pixelated as they should.

However, this is not the same as for the text. Even though I’ve turned off “Smooth text” option, text is still being blurred. This option seems to have no effect at all! Smoothed and not smoothed text looks exactly the same.

Is that bug squashed in 3.2.66?

Apparently not. Please squash it, as Smooth the Text setting is useless now (smoothed and not smoothed text looks exactly the same.

Did you try with a font originaly pixelated?
It might also be your graphic card or even Windows which force-smooth texts. I know there’s that kind of issue with RPG Maker and some emulators.

Yes, font is originally pixelated (made with Fontstruct).