The problem with test reward ads, they only appear the first time (SOLVED)

I have a problem with test reward ads. So, at the beginning of the scene, the ad starts loading and at the same time a loading sprites appear, indicating that the ad is loading. And when the ad is ready to watch, the loading sprites are deleted and the player can click on AdsIconSapphire/AdsIconEmerald to make the ad appear, and then the player gets a reward (Emerald, or Shappire), and the loading sprites are created again. And that works, but the problem is that the new ad should then load and the loading sprites should be deleted again so that the player can click on AdsIconSapphire/AdsIconEmerald again for the new ad to appear, but for some reason that doesn’t happen. I tried without trigger events and with them, but nothing works. Can someone tell me what I did wrong?

First, let me preface this by saying I have never used the ads stuff, and I am not sure if you tried this or not, but when I have a trigger once event with the “touch/left mouse btn down” (actually any key type action) it will not repeat if it is in the same hierarchy of the event. So maybe try making the trigger once a subevent of the “btn down” event with the Show vid and change global var actions. And do that for all the “btn down” events. I hope that might help solve the issue, good luck! :slight_smile:

Thank you, but I already found another way to solve the problem and it works :slight_smile:

1 Like