TimeScale not working properly

Hi all,

I’ve recently come into an issue that is seeming like a bug.

I have this code here that I have not changed and used to work just fine.

Now when I run the preview, no matter how long I set the “wait” to it doesn’t change the timescale at all. Like I said I haven’t changed anything in my code and it worked just fine before I closed the program and re-opened it a day or so later. It is also not working in other parts of my game where I’m attempting to change the timescale for a certain amount of time using the “wait” action.

Any help would be greatly appreciated!

Has gdevelop updated since? Try to see if one of the conditions are messing it up in away, also maybe try making a boolean variable as the time scale

Gdevelop did update I believe. Curious as to what changed in the engine that would have caused that effect. Making a boolean variable for the time scale did seem to fix the issue though. Thank you for the advice on that fix!

Np, hope it works good