Top number keys don't work

I’m making a game for the wiiU and I’m using keymaps for the controllers so I have to use almost all keys on the keyboard.
All was going well until I tried using the top number keys. Its displays them as “Num1” but nothing is happening when I press them.
Can someone help me out?

I just noticed this today too! In editor, it recognizes them, but if you set them as controls in your game, nothing will happen in game. :astonished:

I found a work around using the Fx keys (ie. F1 F2 etc.) but I would like to use the Number keys at the top for the directions for the rest of the gamepads.

I found out that they work after exporting game, which may point to wxWidgets conflicting with testing game (Again…). Coming to think of it, TextEntry extension has similar issue: It doesn’t work in editor but works after export.

Hm… Can’t reproduce. Not in editor, not in exported:

Press 3 to draw red square.

Are you sure you are using newest GD version? Do you have some weird, custom keyboard?

For the record: Azerty, Qwertz and Dvorak keyboards classify as weird custom keyboards.

I’m using a laptop keyboard with full keys including the number pad. I’ll have to try to use those keys on the wiiU but something odd is going on because I have mapped the numpad keys in the engine and they work when testing in the browser but on the wiiU they don’t work. What’s the newest release date?

Be advised that GD officially don’t support consoles and therefore WiiU. It may in future, but not currently.

And newest version is 3.3.71 I believe. Anyway, go to Game Develop General, there’s always sticky there with newest version.

Consoles? Keyboard numbers don’t work on PC (HTML5), at least in the last gdevelop 4 version.

This topic is reaaaaaally old (4 years), next time open a new one :slight_smile:
What version of GD4 do you use?, numpad has always worked, and top row numbers should be working on GD 4.0.97 and GD5 since beta 15.