Touch screen on PC. Little problem

When I mouse over all the event move functions work.
but when I switch to touch drawing, the app switches to phone mode and I can no longer move events with the mouse.

this kind of movement is quite convenient and I would like to know if there is a way to adjust it?

I have Windows 11
Dell Latitude 5490 laptop

1 Like

Hello. I really liked your video on making a mini map, if that was you.
It’s the same for me on a Windows 10 machine.
But when I’m just touching the preview for testing or inside piskel it doesn’t stop me from dragging events with the mouse later.

If you just want to move events with touch instead of mouse for a little bit, you can have your project open and hit ctrl shift i. You might see it’s on the elements tab when it opens. To the right and a little under the bar with the elements tab on it you’ll see another bar. Select the tab that says Event Listeners. Check the box for Ancestors and for the button that says All select Passive instead. Now click the arrow by touchstart. One of the choices under that will say ScreenTypeMeasurer. Click the box that says Remove in front of it. This will temporarily disable that. It almost has no issues…ahem. Next time you start GDevelop it will all be normal again. I would not do it myself but if it is just to give you some relief from mobility issues and you don’t really want to mess up GDevelop itself you can try that.

1 Like