Two bugs:

The first bug I made a video of: I haven’t managed to find out exactly what situation makes it happen yet, but it does happen quite a lot. I think it is always when dragging an event into a sub-event, or copy+paste into a sub event, but I can’t find a more exact cause than this. It only seems to happen sometimes. It can be fixed by selecting any condition in the affected event.

The second bug: :open_mouth:

I have a card game with images for the cards. The most recent images (which are of the same size and format as all other images for cards in the game) are not working at all. I have tried (without success) the following fixes:

-Restarting GD and restarting the computer (and after all the following steps).
-Clearing my browser cache
-Removing the images from the image bank, renaming them and then re-adding them
-Using the image on a different sprite
-Making a new copy of the image in GIMP, deleting the old image from the folder it is in, deleting the red x version of the image in game develop and using this new image.


If it’s about jpg, check in gimp if they’re not progressive (options submenu when you export, it’s activated by default).
If it’s about png, no dpi above 100.

It might be the cause of your first bug too (change in events refreshes the display, and then GD refresh your image in sprite objects, triggering the crash).
It might also trigger because you have somewhere a faulty event that crashes the background compilation (like << instead of <=).

As I mentioned in the original post, all the png files are of the exact same type. i.e. Same DPI (72 I think), same size, all from the same batch export. It just happens that some (most) of them are not working and no matter how many times I try to change their name or type or modify the objects, they will always load fine in the GD editor, but never load the image in the actual game.

No errors are shown during compilation and none show up during the game (other than these missing images). I have tried search and replace to change the object used in this code and with other objects, the same exact code works fine. It is only with certain images (again, same DPI, same file type, same export settings, same file location) that will not load when the game is playing. They do however, load perfectly fine in game develop.
I am 100% certain after trying other objects (that have all worked fine) in place of the ones that are not working that it is not my code at fault. I also am certain it cannot be the images themselves that are the problem, since all images were exported on the exact same settings and size. However, I cannot narrow down the cause of this bug any further it seems. =/

1 Like

For images, try to hit CTRL+F5 to refresh the cache of your browser and force it to reload the images.

This is one of the first things I tried.

It could maybe be related to image name (any unusual character in their file name?)
Could you send me the project?

hmm I fixed second the problem by moving the project to a different folder and then re-exporting the images to that new folder and going through each sprite and editing it’s image to match the new one (I gave them different file names).

If this error comes up again, I will try to give it more attention to see why it is happening (it’s like GD was always trying to reference the deleted image once the game started running or something, very strange).