UI not responding as desired in Android

Hi everyone,
when I preview the game on pc the retry button works well, but when I preview it on any android device it does not work

Pc :point_right:
ezgif.com-video-to-gif1

Android :point_right:
ezgif.com-video-to-gif2

The retry button works in android if the scene is started from this (you lose) scene. If we start the preview from any other scene or from scene 1 and then reach this scene(you lose) it won’t respond as seen above

Preview on android when started from You Lose scene :point_right:
ezgif.com-video-to-gif

Same happens with the second button ( share) also

The events are as follows-

One more thing, the same events were apllied to the play button as well but has no issues!
It works well no matter from which scene I preview
The events for that are -

Please help.

Are you ever using either timer? I see you unpausing them when mouse released on the button (probably should unpause, then start reset them), but don’t see a condition like "Timer few of object Retry is greater than .5 seconds, set global var life to 7 and start Start. Not that I think it’s the problem I was just curious.
Also curious about the pausing scenes to start the other scenes. What is the benefit of pausing the game over scene?

Sorry, but could you explain in simple words what should I do.

Are you using the app or the browser?
Also show the event in another scene that leads to game over scene.

I used the app to preview the game
And I also tried the browser but the problem occurs in both

The scene


Ok. Since you are using the app: copy your project folder. Paste it on your desktop. Edit that so you don’t break anything.

I can’t tell what’s wrong. Maybe Android is not setting your global variable back to 7. But if so, why would that affect the share button.

Thanks for your feedback

Someone please reply

Hi abc, I didn’t have a good look at your events, but sometimes when things haven’t worked for me as expected with Mouse button was released, I change it to Mouse button is down and then it works.

To experiment with this, you could put Pause the scene and start Start in the Mouse button is down event.

It did not work. What should I do now?

Someone Please help :no_mouth::question::question:

Hello!

I sadly don’t have any good suggestions for you, but must ask you as a matter of forum rules and decorum to please stop self-bumping your own thread.

Unfortunately, there is a chance no one will have an answer for you, and bumping the thread won’t override that.

I tested your events on my phone and it works. Did you try testing those events in an empty project? Just to see if it’s the code or the project/ other events. Maybe something else is interfering. Does the button have any other behavior besides tween?

One of the differences between a touch screen and a PC with a mouse is on the touch screen the cursor only moves when the screen is touched. Some of your events happen simultaneously but that didn’t cause any problems for me. You can’t do a mouse over type of event on a touch screen without also triggering a touch or mouse pressed event. Also, the cursor won’t leave the touched position unless another point is clicked or dragged to another point.

Sorry for that (20 char)

I created a new project and used same events there , it worked fine
Only tween behaviour was applied to the object.

So it has been 2 weeks since I posted this post
I tried from myself but still the buttons are not working on Android

  1. Make sure you’re on a version of android that actually uses the supported minimum SDK GDevelop uses (Android 9 or newer)
  2. Check to ensure whether any of the other example projects work on your device.
  3. Check if your project works in something like bluestacks.

If the example projects work, then it’s something with your project. If your project works in bluestacks, it’s something with your android device.

Outside of the above, unfortunately there’s not much else guidance we can give you.