Unable to preview a game

Pardon me, the problem is now there’s no way to test the game. Even trying preview a blank project, it keeps showing the same error message: “Compilation of events failed, and scene cannot be previewed. Please report this problem to Game Develop’s developer, joining this file:

Is there a way to fix it?

Yes, go to /tmp/GDTemporaries/ and paste here the file called LastCompilationOutput.txt

Be sure to use the latest version of Ubuntu ( 12.10 ) as Ubuntu 12.04 and previous versions are not compatible :slight_smile:

Here’s the text on the last compilation output:

In file included from /home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/bits/basic_string.h:41:0,

             from /home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/string:54,

             from /home/majikkumausu/Game Develop/CppPlatform/include/GDL/GDL/EventsPrecompiledHeader.h:5,

             from <linha-de-comando>:0:

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h: Na função ‘_Atomic_word __gnu_cxx::__exchange_and_add(volatile _Atomic_word*, int)’:

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h:48:45: erro: ‘__ATOMIC_ACQ_REL’ was not declared in this scope

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h:48:61: erro: ‘__atomic_fetch_add’ was not declared in this scope

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h: Na função ‘void __gnu_cxx::__atomic_add(volatile _Atomic_word*, int)’:

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h:52:38: erro: ‘__ATOMIC_ACQ_REL’ was not declared in this scope

/home/majikkumausu/Game Develop/CppPlatform/include/linux/usr/include/c++/4.7/ext/atomicity.h:52:54: erro: ‘__atomic_fetch_add’ was not declared in this scope

In fact I’m still using Ubuntu 12.04. I still use it because the long term support, but seems like I need install the 12.10 version to make it work. In any case, thank you for the support ^^

I’ve updated the system, but the error continues. Beside this, the same bug of frozen frames returned.

Please, sorry for sending only bad new and problems about the software.

Can you paste here again the contents of LastCompilationOutput.txt?

Can you remember me what is this bug?

Of course. :slight_smile:

And the problems I mentioned was reported here: viewtopic.php?f=20&t=3961

Are you sure you’re really using Ubuntu 12.10 ?

Launch a terminal, type “gcc -v” ( without the quotes ) and then press Enter and paste here the information shown by the terminal.

Certainly. And I’m still using the 12.10 version, just to inform:

Your gcc version is 4.6 while it should be 4.7. Did you installed anything particular related to gcc ?
Try to update it to the 4.7 version.

SOLVED! In part. I was having trouble to update the GCC to the 4.7 version. Luckily, following this instructions from here charette.no-ip.com:81/programmin … 24_GCCv47/ helped a lot. Now it’s possible preview and run the game.

However, again the windows continue freezing, but it’s a topic for another topic. Thank you for the help, 4ian ^^