Very frustrating issue with sprites


This is my first day using Gdevelop, and I’m already having problems :frowning:

I want to create “triangle drones” to rotate towards the mouse, but no matter what I do, the rotation is always off! I’ve tried changing the centerpoint, and even rotating the image itself.

Other images I downloaded off Google had the same problem.

Any tips on how to fix this?

Probably the sprites facing the wrong direction, make sure all the images facing right as that is the default direction in GDevelop.

Thanks for the help!

Update: I did have a question here, but I solved the problem on my own :smiley:

Actually, I do have another problem :wink:

Apparently, the “do this on shift key” doesn’t want to work, although “any key” does, along with others (like space). Am I doing something wrong?

It could possibly be because of the weird dialog box I get when trying to use the Shift key, telling me to click “Yes” for left and “No” for right. In fact, it seems that ANY event that brings up that dialog box won’t work… maybe it’s just a bug.

Also, and perhaps more importantly, is there any way to specify the size of an image when it spawns? Thanks!

On which OS are you working?
Does GD name the key input as “LShift” or “RShift” in the events? :slight_smile:


I am definitely using the right OS, but it still won’t work.

I ended up finishing the game, but now I have even more issues with exporting. My images won’t appear, so I figured I could just upload them to the Internet, and paste the url in the javascript. I tried going into the JS files to change the image sources to URLs, but that just broke everything D:

So, is there any way to do this? Or can I make the image source a URL from within Gdevelop?

Also, this is not related, but do you know any way to make borders in a game?

Sorry for all the questions… I love using Gdevelop, but there are so few resources to learn from. :frowning:

What do you mean by “not appearing” ? Does the game plays but without the pictures or does the game loading get stuck (with written “XX %”, XX as a number) ?

Wow, thank you so much for the reply!

Here is what I mean:

That is my game, with none of the images loaded. When I made the game in Gdevelop, I had images stored on my computer, such as “Drone.png”. It worked fine then.

When I put it on my website, the images will not load. I understand why they aren’t loading (the original images are on my computer, not the Internet), but I do not know where I need to store the images for them to load online.

Other people got this to work for their games, but I am lost. I tried going into the Javascript and replacing every instance of “Drone.png” with a link to the same image stored online, but that did not work.

I also tried going into Gdevelop and inserting a link as my image source, but I couldn’t figure out how.

Do you have any tips? Thanks.

Your link is giving error 404, i guess the right adress is “only” : ?

idk what you did but you need to upload the whole exported html5 project to the website, not only .html files. upload the whole directory of your game (the directory where your export), it’s supposed to wrok like this.

It’s simple, just copy the whole folder you get when you export your project on the website. The engine will look for the images next to the HTML page (and that’s where they are exported).

Edit: I finally got everything to work! Thank you so much for your help, everyone, with me and my silly game :slight_smile: