Video not playing

Hi, I am trying to play a video in my game but it never plays.
It just stays black.
I am using an mp4 h264 with AAC audio as it is advised in the wiki.
I know the command is working because all other actions in the same condition are working.
All I see is the black sprite of the video and not playing anything on the screen.
The file is 45MB but I have also tried with other sizes and that is not the problem.

Any advice on how I can fix this issue?

Here are the missing Screen Shots

Hi Jeromck and welcome. I know you said that everything else in the event is working, but before the experts get here, what happens if you put **play video** back in the main event and move **Change animation to 1** to the end of the actions. That way you’re giving the other actions a chance to happen while the animation is still 0.

Hi, thank you for the response.
I have done as you said, also I am using the video of the Gdevelop Video example project to be sure the video is not the problem. But I am stuck with the same result. The video will not play. The difference with this new file is that it shows the first frame of the video, unlike my other video which just stays black.

I am using this video from the example and it stays frozen in the first frame.

Problem solved.
The video was not playing because I was trying Safari web browser.
It needs to be muted in order to show.