Yarn - Commands not working/merging text

I’ve seen some posts related to this, but have been left unanswered for a while, so I figured I would try and write a post to see if it caught anyone’s eye.

I’m working on a visual novel game presently, and I’ve designed it where the first thing you’re greeted with is an options list that asks which character you want to meet. I wrote in the Yarn editor that each node calls a separate Avatar command that displays the correlating character to display.

But instead of calling the character, it leaves the avatar hidden, and instead merges dialogue lines. It even merges dialogue across nodes. I haven’t found a workaround for the problem yet - if someone can at least give me a different method to make this work until the Yarn commands get fixed, that would be wholly appreciated.

Screenshots included in replies below:

Events Page:

I’ve replicated my logic from a previous test file I did to learn how Yarn worked. The only difference is now adding the “avatar” command logic, which is for some reason not working like it should.

Yarn Editor:

This is what I have written for my initial put-together, just to test and make sure the main features are working before I get too deep into transferring my script.

Initial Options List:

As you can see here, the initial text and options dialogue displays perfectly before any commands are called.

Result if I select Gemini:

Upon selecting one of the characters, her art does not appear, and the two dialogue lines in her node around the command get merged together. I’ve also tried different ways of arranging the command, and it’s even led to more lines piling up with the merging effect as I try and progress the text.

Hello GuidingKey,
I state that the dialogues are difficult for me too, but I try to make my contribution.

Can you show me the avatar animations ? In the pictures I can see the question mark (no animation).
Is the change animation command is by name ?

About the missing new line, I have inserted a blank line in Yarn. I know that is not the correct solution but it works :slight_smile:

Here’s the avatar animations.

I have it set to where the command calls the character’s name, which associates with the named animation on my avatar object. It starts with an empty animation so it doesn’t display until the command calls which character is supposed to display.

I do have it set by the change animation by name event in the actual event logic, as well.

I also tried the blank line, but it didn’t work. The dialogue only works correctly if I remove the command from it, for some reason.

Thanks for the feedback, J!