Android 6 no longer supported?

I bought a bunch of old android 6 phones for a school project, and before I bought them I tested out some gdevelop projects I have online from a year ago and they worked great.

However, when I tried exporting a project from the latest gdevelop it just shows a black screen on those devices.

I tried:

Exporting the working project from a year ago and the fresh export yields a black screen. (but works fine on newer device)

Creating a project with two static jpegs - black screen (but fine on newer device)

Opening a project from a year ago with 20+megs of HD assets, gps, mqtt and even an HD video - Played back really well. (to my surprise)

Any thoughts on what has changed in gdevelop that would leave android 6 (or this particular phone) incapable of displaying anything (including the loading graphic)?
(same result from web publish and apk publish)

I’m assuming that there isn’t an option to backslush to an older gdevelop (not that I’d really want to, but I did buy 20 of these devices)

If it means anything, the devices are “vodaphone” smart phones model vfd300, android 6, patch: 5 december 2017, baseband MOLY.WR8.W1449.MD.WG.MP.V57.P15, kernal 3.18.19+, build number: MRA58K release-keys.

I don’t know that Android 6 has been officially supported for a long time, but I don’t think it has necessarily been blocked. If it was blocked you wouldn’t be able to install the apk, as far as I know.

From what I understand Android OS version support is mostly determined by Cordova, Electron, and minimum SDK requirements from Google. If it IS an minSDK issue, you might be able to manually export it if you modify your (Manually) exported project and change your SDK requirements in Cordova?

Unfortunately, the specifics on how is beyond me as I believe those are Cordova specific.

Note: Electron is using Chromium for rendering, so if Chromium has removed support from/blacklisted those devices for WebGL support, they likely won’t work even if the SDK/OS requirements are still valid.

Since the html5 version exhibits the same behavior, that would imply the issue wasn’t cordova/sdk requirements, right?

Did we change to a newer version of electron in the past year that perhaps is incompatible with older devices?

Hmm. it appears that chromium dropped support for android 6 with chromium m107 released in october.

That makes sense, and unfortunately not something that would be controllable on the GDevelop end.

If you do some digging, you could see if you can get an older version of Electron to compile with, but I cannot begin to know what would be required to start that.

I’m probably stating the obvious, but oh well. Have you looked into upgrading the phones from Android 6 to something newer using whatever method it takes to do it?

In case anybody else ever runs into this problem, running an old version of gdevelop works. I found my old installer for 5.0.128 and it was able to generate web files that worked on the default android 6.0 chrome. Additionally, 5.0.128 was able to use the online apk creation for android and it installed and worked correctly. - which seemingly confirms that the issue was not an issue with cordova or sdk requirements. Cheers for helping me through this!

Please note: Your statement above is actually the inverse of what it shows you. Your exported project includes the SDK requirements and cordova settings in the source code and project configuration. Older versions would have older SDK requirements in the project file.

That said, none of these thing make much sense on why the web version wouldn’t work. That would imply a WebGL blacklist/support issue.