Android Blank Screen

Hi there,

I have created a small prototype of a game in GDevelop and the android apk either says ‘game name has stopped working’ or the screen stays blank, no gdevelop logo, no nothing, just a black screen, I have left it for 30+ mins but it never changes.

I have tried:
The 1 click export in gdevelop
the local export and whole mission to build the apk with cordova, the build succeeds but has the same problem - blank screen, nothing happens
checked resources, nothing seems to be wrong there
tried using adobe phonegap to build - same thing again, blank screen.
hours of googling and frustration, none of the solutions I have found have solved the problem including the one tagged [solved] on this very forum.

FYI: I have a working Web build of the same project on Kongregate but the android build refuses to work not matter what. The windows build (exe) also works.

EDIT: I have also tried the network preview in my phone browser and that is also just blank.

please help

Sure you filled the package name, device orientation, author name, version and icons?
Did you try it on several Android devices?
Could be that your json file got corrupted somehow :man_shrugging:
If you want to share it, we’ll take a look.

Package name = yes
Device orientation = yes
author name = yes
version = yes
icons = no (it has the cordova icon by default)

tried different android devices = yes

Will try adding icon files.
How can I share the project with you to have a look?

Adding icons did not work

I suppose that if it doesn’t load at all, the json file should be enough (it’s in the project’s folder).

Sent link in private message

It doesn’t seem corrupted, online validator says it’s valid :man_shrugging:
Not sure what it could be. I can’t open it in GDev but I suppose that’s because it’s a multiples files project.
Let’s wait for others. :slightly_smiling_face:
Has it never worked or did it stop working?

The android build has never worked, web and pc have always been fine.
Thanks for having a look :slight_smile:
Let’s see if anyone else has any ideas, if I ever figure it out I will post the solution here.

hi, tried to do a new project and copy/paste?? don’t know if it is a huge project


I tried that as well, same problem.
I also tried making a new blank project, just put some text in the scene and the am having the same problem, I don’t think this problem is project related, it seems to be a bug with the GDevelop export to android.

which version of gdevelop? I don’t have a problem, maybe is something with your account, try another or send the project I’ll compile and try in my phone.