AppImage problem: Segmentation Fault (Core Dumped) (Need help)

AppImages builds won’t run, no matter what I do to solve this issue.

As a Linux user, this is very frustrating. Terminal won’t help either, as I only get this message: Segmentation Fault (Core Dumped), and no more details. Tried to search on google, but nothing helps.

I found an old topic about it and no one answered:

Look, I need help on this problem, as I’m having a very important project running on GDevelop and need to deploy demos on

Anyone having this issue in your Linux distribution? Or is it just me? Thanks in advance.

1 Like

If you want to upload demos on, you can export to HTML game, you won’t have build issues.
Did you try to run your build on another machine/OS?

Hi, thanks for responding.

I mean I wanna build native ones so I can make them available to download, including AppImages for Linux distros (which aren’t working).

I’ll be testing it in my wife’s laptop in the following hours and come back here to post an update then. Thank you

i can test it on my linux. I only compiled my game for android could try for linux and see what happens

Sorry for the double post. It worked on my wife’s laptop on Linux Mint. I believe this has something to do with the distro I’m using then. I’ll get in touch with Lubuntu devs and see what we can do. Really thanks

@xisco Thanks for your help. Did it work?

Update: So, as I don’t have time available to find a way to fix this issue, I chose to switch to Manjaro Deepin and now my game’s AppImage is working as intended :smiley: Thanks, guys