BBtext line height

Since the update to the BBtext object to fix fonts, it seems the line height on previews and export is a bit squished. In addition to these screenshots, you can compare my app in Chrome and Firefox. This is a layer in the Studio when clicking the question mark icon at the bottom.

On Chrome, it looks more like the preview below without the extra space between the text objects and color charts. On Firefox, the spaces between lines are more visible and the color chart overlaps some of the text.

Scene Editor
I tried to add space between the lines

The space mentioned above is still there in the object, but it shrinks on preview

Without the extra spaces, the lines overlap each other a bit.

@Silver-Streak will explain more than me, he know so much about fonts.

@Phenomena We need to be sure at that come only in last build (n89), can you save your project and open it on previous build (b88), and take screenshoots for compare in preview and editor, if this is true this need to be reported on github. (We have lot of contributors currently maybe someone can help us)

But this is strange because use the resource loader (b89) or just a string(b88) is equal, because both use the name of the font for display it.

1 Like

It’s not the font itself; I’m using the same one for tips on mouse over + the random ones that show on the main menu scene and there’s no issue with multiple lines. They are regular text objects though, whereas the texts in my screenshots are done with the BBtext object.

I’d have to download the older release, retake and upload all the images.
Unfortunately, I’m out of time today. :frowning:

Hey Phenomena,

Bouh pinged me just because I’ve been dealing with lots of font issues in my game. There’s 2 different things I’ve been experiencing, but what you’re describing is very similar to one of them.

This appears to impact both BBText AND Text object. I would definitely do as Bouh suggests and try an older version to see if it still occurs. If it does, I’d say check this entry I have over on Github to see if it matches your issue. Custom Fonts at large font size being rendered in IDE with Default Font Render Box/Wrong Location · Issue #1419 · 4ian/GDevelop · GitHub

1 Like

Hi, just had a look at your report and it’s probably related, if not exactly the same problem. I tried other fonts too and am using it elsewhere in the app without an issue though, that’s why I said it doesn’t seem specific to the font. Not trying to be mean or uncooperative here, but doing as Bouh suggests will have to wait as I have other plans tonight.

Take your time, this can be done when you want. Contributors are present, others come each week now and they will stay here for a long time i hope :slight_smile:

If something has change betweens two build this allow us to see the code changed in the past, and better understand what going on for thinking a new fix.


@blurymind you have used code from this repo?
Maybe the issue on the repo is related to this bug.

I think lineHeight is missing, or the value by default should be the value living in the font file, what you think?
It’s cool the issue seem global, and not just on GDevelop, in this case digging forums can help, we need research and more comments for understand.

I copy/paste this post on the issue on GD repo.

For me the next one have same problem:

Back a bit sooner than I expected and digging in now.

I did as suggested; downloaded version 88 and took new screenshots.

It does seem to have fixed the line height; I had to remove the extra spaces.

Scene Editor


I’ll report it on GitHub and include both sets of screenshots.

Should I make a new report or use an existing/related one?

Edit: I see it was reported already, disregard the statement and question above :slight_smile:
Thanks @Bouh and @Silver-Streak

Any news on this issue?

1 Like