Broken compilation - using several addons

I needed to test level select for my game, so I compiled it. However, when I run it, after entering the first level and shooting something, it crashes! That same level works just fine in the editor. I had another friend test it, and they crashed while opening one of the doors on the level. Here’s a link to the error message: … authuser=0 (not including the compiled version, because Google Drive thinks it’s a virus :confused: ) Any help would be greatly appreciated.

Did you try to compile without Wine (in a Windows computer)? Just to know if the problem is in GD side or Wine has something to do with that :slight_smile:

Yes, both the wine-compiled version and the native version produce similar errors.

The bug seems related to the LinkedObjects extensions.

Any idea how I could fix it?

I’ve isolated the bug, at runtime the project in memory was not containing the list of extensions used by the game and so the extension LinkedObjects was not notified of changes in the game (so it ended with manipulating destroyed objects).
I’m making a fix for it and adding tests to ensure that it won’t reproduce in the future.

I’ll make a new release with the fix soon :slight_smile:
Thanks for reporting the bug. :slight_smile:

No problem, thank you for fixing it :smiley:

Could you let me know once it’s ready?

Gdevelop will let you know that there is a new version available :slight_smile:
But I’ll post hère a message if you wish. Your game looks promising in any case, good luck with it !! :smiley:

Thank you very much! :smiley:

New version is available with lots of new things and the fix for this bug:

I’ll made it publicly available soon if everything works well! Let me know if your problem is solved! :slight_smile: