BUG in Gdevelop cannot return variables always get ZERO(SOLVED - not a bug my mistake)


Even in this example I only get ZERO value for each variable. It simply won’t work and I am trying to implement a leaderboard in my game, can you guys fix this?

This example doesn’t works because the URL https://swapi.co/ used is not available anymore.
Seem their domain was not available.
That is the cause of the zero data.
There is no issue on how parse json, just there is no json found on their website.

Yes then how do you explain when I try to get variables back from my own server it always returns zero?

Can you upload a working example of a GET from a URL working?

See this file:


THat echos out a variable from my database. No matter hwat I try in Gdevelop I cannot get that value to show up in a text box.

Here is a basic example of what I am trying to do:

that’s a gdevelop file, download it and open it in Gdevelop.

It returns zero no matter what I try. I have set all permissions to read and write on my SQL. and if you open that php file it echos a variable.

Even the error variable returns the value zero as well.

I just tried to edit my .htaccess file and put this inside it:

Header add Access-Control-Allow-Origin “*”
Header add Access-Control-Allow-Methods “PUT, GET, POST, DELETE, OPTIONS”

That didn’t work either. There has to be something wrong. Even the error variable is showing up as zero…

Your web server returns a 500 error on all urls you posted and has ssl wrongly configured. That alone may be the cause of your problems but you also ignored my advice 13 days ago when I told you to take into account that Firebase actions are asynchronous and that you cannot get their result directly after calling it. Network actions are asynchronous as well, and I guess you haven’t bothered adapting your code to take that into account if you did not back then.