bug Linux - random Crashes

In this thread I will document terminal crash logs from gamedevelop, while testing on the “example” scenes.
manjaro Linux-Game Develop, built 4/01/2014

First one:

Unloaded compiled code0x4a19400 StartGameDevelop.sh: line 7: 3884 Segmentation fault (core dumped) ./GDIDE

If you want to help me with fatal crash, you can do the following:

-Go in GD folder with a terminal,
-Type export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. ( do not forget the . at the end )
-Then type gdb GDIDE to launch the GNU debugger.
-Type r and press Enter to launch Game Develop
-When it crashs, type bt and press Enter in the terminal to show more information.

You can then send me the information shown after bt.

If you manage to reproduce a bug, you can also send me the .gdg file as well as an explanation on how to reproduce the bug :slight_smile:

I tried this and it doesnt seem to start because my environment is not set for debugging.

Maybe it’s because I am on an arch based distro?

Sorry, I forgot a word in the process that I’ve explained in my message:

Now it works! You should sticky these debug instructions in this forum. Really helpful.

Now I managed to crash it and find out more about why it crashes.
This seems to be an instability of the UI toolkit of the editor. To trigger the crash I did the following:

  1. Open the platformer example
  2. Play the game (preview)- native platform
  3. Open the debug window- when it’s opened it is a part of the editor layout
  4. Drag out the debug window- so its not a part of the editor layout- and it is an individual window. And at that point everything freezes!

Here is the crash log:

It’s not the whole thing, because I figure its too long. This forum doesnt have [code] tags. I assume that you are mostly interested in the last lines of the log. If you need the entire thing, here is a pastebin:

Nice, just one more thing, it would be insanely helpful if you could type “bt” in the platform after the crash so that other information are displayed :slight_smile:

(Because for now all the information are normal and do not show any problem)

It does say segmentation fault at the end

Ok I repeated the steps for the bug and it didnt crash again for the platformer example. However I closed the platformer example and then opened the rain example. Then started it and when clicking on the “debugger” button to open the debugger, the same crash as before:

Here is the entire terminal log, with BT included:

Note- bt starts at line 444

Thanks, the information show that the crash was provoked during the autosave.
You may consider disabling it to improve stability for now!

Thank you. I will disable it. Maybe the next linux release will have it disabled by default? :slight_smile: