Button is Pressed not appears [SOLVED]


I’m very newbie here and this is my first message. I wish to post for another topic to get help but I found a mistake or a bug in Gdevelop.

In Gdevelop’s tutorial wiki >> http://wiki.compilgames.net/doku.php/gdevelop/tutorials/beginnertutorial2 there is a section to add mouse conditon is which “Mouse button pressed” in normaly. However in my copy of Gdevelop’s that section has no!..

Then I tried another one is that Key Pressed to launch bullet fire but that does not work too in preview.



It’s “Mouse button down or touch held”. :wink:

Umm thank you for your reply. Unfortunately that does not work too :frowning: . On the wiki’s guide steps that I implement to my project not work until now. Mouse clicks not launch bullet, enemy tanks not comes toward to my turret, explosions do not happen. :cry:

I use Gdevelop on W10 OS that maybe reason :question:

This should work. Do you set “Left” (without ") in the mouse button down condition ?

Yep I have typed it as you type. However nothing happens when I go to preview on browser.

Have you set the image of Bullet ? and Enemy ? (I told that because their icon is blank in the object editor shown on the screenshot)

Yes I have done however they are not shown in Object’s editor. As you said the problem is on that section. What can I do to solve that?


I have solved the problem.

Why that happened have no any idea. After some tries to solve it then I found the solution. Firstly I had added all Object’s Sprite again. Then drag&drop images from Image’s bank editor to images section of Edit the Sprite panel. After all these my project’s assests worked very well. :smiley:

My propasal is that adding sprite should be automated not manually.

Thanks for all your help :slight_smile:

Yes, you need to drag the image from the image bank to the frame list to add it to the object. Just selecting it in the image bank is not enough.