Error: External layout unable to load.

Hey everyone, I’m making a game with the now outdated gdevelop 4. Recently I’ve been getting an IDE error, saying “Unable to launch External Editor,” and the details it states, “Execution of command, ‘/Users/florian/Projects/F/GD/newIDE/electron-app/node_modules/electron/dist/… 15:16:56.’ ‘Unable to launch the external editor,’” if anyone can help I’d really appreciate it! The game I’m working on means a lot to me, and it crushes me if I have to stop using this engine! Whenever I exit out of the error message the scene only says: “The Editor is being loaded (This may take a few seconds),” I’ve registered to this forum, made and drank a cup of coffee, slept for an hour, and it’s still loading. I’ve tried reinstalling gdevelop and tried to see if my project’s file is corrupted and every other gdevelop project of mine is having the same issue. I don’t know what to do and would love an answer.


Wich version of GD4 are you using, and wich OS ? it’s really strange to get an error related to in gd4 !

I’m using windows 7 pro (which is strange since the error is saying MAC), and I’m using, and thanks for the concern!

Can you try to open the project on another computer ?
Or maybe try to install the zipped version instead of auto-installer :

Does it happen when you try to load/compile an example (with ou without external layouts ?)?

Hey Kink, my game is entirely based off the wolfenstein 3d example. I just tried to open another example and compiled it to native. It says Fatal error execution engine unable to load layout “Game ,” also good idea with github i’ll try it right now!

Okay github didn’t work, but lucky the computer I’ve been using isn’t my main computer. All should have to do is get a flash drive and put it on my main PC. But thanks kink!

Hello, all the best to you! Sorry my english, I’m from Brazil and I’m starting to study english language yet.
I had the same problem and saw that an option was marked in:
file>options>general>use the experimental, new scene editor
checked=false and not true