[Fixed at Version 127] Sound Bug since version 107 till 117

I don’t know how to describe it properly, after each action my jump sound and coin sound bugs sometimes, its like I hear the noisy version of first 0.1 sec of the jump sound or coin sound.

Its much more prominent if I select play a music(action)

I was sticking to 104 version, because sounds works fine in it, all the versions after have this.
Im worried because I can’t upload to Google Play with 104 version, I think not many people are experiencing this and is not fixed in the many updates.

I was about to publish my game and now this strange bug, I can’t seem to find a solution, please help

You can even try you self, with the event below but this forum does not allow audio files so, try a short jump sound
and press the button repeatedly fast till u get that annoying glitch sound. It happens 1 out of 20 times

Try it in the link here, press w fast for 30 sec to a min


I have also made a video demonstrations of this issue

1 Like

Hey Omar,

When I have reported sound issues on github I have found it helps you (and the Gdev team) a lot if you’re able to replicate the issue in a new project.

That way they can clearly see that it’s nothing to do with your current logic + makes it easier to track down the issue.

My last image in the post is of a new project, with that issue and no other events

Its just there is no way of sending audio files here

The two sounds that are causing this problem are .wav files of jump & coin made from in engine audio tool, created in 2020, August Version of Gdevelop 5

Im wondering if I convert them to mp3 maybe will solve the issue, or getting new sound effects

Unfortunately, I can’t reproduce your issue. I just tried setting a button to play the death sound in the example platformer project, and slammed on it like no tomorrow without any distortion.

Here’s an example export. https://game-previews.gdevelop-app.com/1631624682773-23239/index.html (T on keyboard to play sound). It is also using a wav file.

I have both of my wav sounds with this problem, please give me your gmail, facebook or whatsapp, so I can send u the audio files and video of how it happens

I have tried converting to mp3 and increasing & decreasing the length of the track but still same
To make it more scientific it still happens on other devices I even installed new copy of Gdevelop on my Laptop
I also packaged apk on my android still same

Sorry, nothing I can do with help you if your specific sound files won’t work, while the others in the example above don’t reproduce the issue, so sending me the sound files wouldn’t help.

Next steps would likely be to see if anyone else experiences the issue with their own audio files, or if a contributor has any input.

Wait, now I have even created new sound files from Jfxr editor, same issue.

The thing is longer than 0.5 sec sounds don’t have this problem, but very short sounds like jump have

You have to press button very fast for atleast 30 sec, It does happen I have now even replicated with multiple new sounds, its a loud bug like sound

If you don’t want to see my files for some reason, please try multiple short jump sounds created in sound editor

I don’t have access to any systems to download your files right now, so I’m just testing real quickly using the built in examples.

Using the player hurt sound in Not-a-vania, which is also made in JFXR, and also less than half a second, I still can’t reproduce the issue. You can test here and spam as much as you want with the “1” key. https://game-previews.gdevelop-app.com/1631626548425-118207/index.html

Just to check, are you setting your files to preload as sounds in resources? I could see something going weird if they’re not being preloaded, and maybe overloading the buffer.

I have also tried preloading sound, still same

Try this now I uploaded a fresh project with the issue

Hit w really fast for at least 30 sec to min

Also please try this simple thing I won’t complain you again,
Try 3 different jump sounds created by Jfxr
And hit the button fast for 30 sec
It happens to me in almost every jump sound effect created from Jfxr

My game is about jumping, this is a big issue for me, Im about to publish my game jump up top next month.

I have no issue in 104 version, but as you know its not possible to upload to google play this that now

I’m sorry, I cannot reproduce the issue with your export URL above, even after 2 minutes of spamming W.

As mentioned above, I don’t have access to any systems that can download files currently, which also means I cannot access JFXR (not available in the online client).

I’ll try and take a look later today to see if I can reproduce it on a local install, but if anyone else can reproduce they’re welcome to chime in here.

1 Like

I had a chance to log onto my home computer, and set up a test project.

3 different sound files, all made with JFXR. Each can be activated by pressing the number 1, 2, or 3 keys. Note #2 has a bit of a clipped sound at the end as part of its effect.

I can spam them (all at once, even) over 60 seconds without any distortion.

Here’s my events:

Here’s the resources:

At this point, I can’t assist any further, but if anyone else is able to reproduce the issue they may be able to diagnose more.

Finally I got it, It happens in the lower volume levels below 70. you had volume set to 100 and my was 5 or 7.

I have now tested many times

Try this one last time
Press repeatedly Num 1 or 2 for a min, change your press speed randomly

also to confirm my theory please send your 3 sounds project again, with volume set to 5

Just to give my experience, some times happen to me if the file is a .wav and you try to set the volume below 20 the sound plays but you can’t hear anything I don’t know why but it happens to me in some games.

Had another chance to test this, both at 20 volume and 5 volume.

Still no difference.

Here’s the example with the volume set to 5 on each.


Please note: you’re using the “Play the sound” action in your screenshot. You may very well be overloading the sound buffer since you’re playing everything on the same channel.

You should be using the “Play the sound on a channel” action, with each type of sound being a different channel. (Music on channel 0, menu sounds on channel 1, player hurt on channel 2, player attack on channel 3, enemy type 1 sounds on channel 4, etc).

1 Like

I was able to see or I guess hear, the bug with the latest version supplied by OP (https://games.gdevelop-app.com/game-dab3b41d-0362-4e9a-acb2-76508a6bb529/index.html).

I have recorded a video with OBS including the sound levels where you can see it peak.

1 Like

Can you try changing the events over to separate sound channels to see if it still occurs?

I have tried your example with 5 volume, and yes all sounds made that bug sound, No. 3 had most common.

So yes lower volume does make that sound more common, as well as high pitch short sounds

I don’t know why you are not getting it, maybe your not pressing hard enough

I also tried with different channel, same result

I don’t know what to tell you. Spammed it while recording in OBS. There are no audio spikes despite hitting it fast enough that the sound never stops (except when I hit a key combo by accident). Even threw in the other sound presses to be sure.

My best guess is that it is a sound buffer issue, and some integrated audio has lower buffers available than others.

If a contributor can take a look with more input, maybe they can determine whether it’s fixable or an audio device compatibility issue.

I have no clue what might be causing this, but since it does not seem to be reproducible by everyone I’d say it probably isn’t a GDevelop problem but an issue with either your version of the Chrome/whatever browser you use’s WebAudio API implementation that is used by GDevelop to play sounds or your sound hardware.

I don’t know what exactly is causing this, but we must find out if its a bug in the engine or something not related to Gdevelop, but it does actually happen to some people.

and its only after build 106 of Gdevelop 5, lower volume levels and high pitch short sounds

I will try on 2 other pc to see if hardware makes any difference