Game wont load and gets stuck in the loading screen

when i try to preview the game it dosent load
it just stays like that


I am actually having a similar problem.

Is this on the PC or web version of the GDevelop editor?

I am having the same problem. I tried to restart GDevelop but the problem remains.

its on my pc i never had this problem happen to me before

I’ve moved this to GDevelop bug reports since it’s happened to a number of devs.

aight, atleast its not only me, could it be the update doing this?

Here is some additional information:
I am using a Mac. I have tried both the silicon version and the Intel version (GD 5.2.175) with the same problem. It also happens with a compiled app. BUT it doesn’t happen with all my games. I just created a new project without any problems. Maybe there is some specific events that trigger the problem?

same here, but i use a windows with a intel processor

Now I downloaded and installed 5.2.172 and it works fine again. I also unchecked automatic updates.

Hi, can you please save the project locally “File > Save as”, zip it, and either share it here or send it to

We can take a look but we need a project to reproduce the problem.

1 Like

Just to remind everyone: the only way to help us debug this and improve GDevelop is by sending us an example project so we can fix the bug for you.
Thank you! :slight_smile:


Thank you for sharing your project!

I’ve tried loading it on different machines (windows/mac) and the preview runs correctly on my side…

2 questions @NiroMcMuffin

  • Where is your project saved usually, in the cloud or on your PC?
  • If you try to re-open the project you just sent (Unzip it, and File > Open > select the .json file) is the preview still not working for you?

Thanks for your answers

i use a windows device, and the game is saved on my pc, i tried going back to a older update,which seemed to work, thanks anyways

I couldn’t reproduce it either unfortunately

weird, well, thanks for trying anyways :wink: