Games choppy when running

Hi, as title said, game’s choppy when running no matter if I turn on vsync or not (I limit frame rate at 60). I know that if you increase framerate, then game will run more smoother, but that will also increase the cpu usage, running a simple 2d game with over 50% cpu usage is just ridiculous. Is there’s anyway to smoother the game while limit it to run on 60fps? Thanks.

Hi, you shouldn’t have smoothing problems at 60 fps, it’s really enough to make your game smooth. If the image is cut when there is a lot of movements, you can enable V-sync (and donb’t forget to re-open the scene afterwards).

If I remember correctly, I also experience chopping when framerate is limited at 60 fps : I tried to apply some solutions but for now I did not find the correct one.
However, activating Vsync and disabling the framerate limit seems to produce a game without chopping which runs at ~60 fps.