GD doesn't load up

Okay so i installed GD and went to load it up from the shortcut and nothing happens, is there an error log stored anywhere?

What is your operating system ?
What is the version of Game Develop you want to install ? ( Launch help from Start Menu > Game Develop > Help, and go to the last section : About > Revision History, then paste here the first numbers. For example 1.5.9979.50340 )

If you’re using Windows XP and a recently downloaded version of Game Develop, go to the Game Develop folder ( C:\Program Files\Compil Games\Game Develop ) and delete the file called “GDEditor.exe.Manifest”. Try to relaunch then Game Develop.

I’m on Windows 7 64bit and only downloaded it the other day so it should be a fairly new build.

Clicking the help file did nothing as well - i had to manually browse to the folder to find the file, revision is “1.5.9979.50340”

Also a tip - Add the version number you are downloading to the download page - a fairly big thing to miss out!

EDIT : I’ve corrected the non working help shortcut. Thanks.

It is the latest build indeed. I also use myself Windows 7 64 bits so as to develop Game Develop.

In fact, as Game Develop has a mechanism checking for updates at each startup of the program ( or on demand ), I don’t think it is necessary ( I also post a message for each new version, but currently only on the French forum )

First of all, be sure that your video card driver are up to date. ( What is your video card by the way ? )
Be sure to update them then try to relaunch Game Develop. ( Post a message so as to notice me if GD work after updating the drivers )

If I does not work You can help me to track the bug :
-First, downloaded and extract Dependency Walker :
-Launch it ( Depends.exe ) and then click on File > Open and select the executable of Game Develop ( GDEditor.exe, in the Game Develop folder ).
-Click on Profile > start Profiling and click on Ok. Game Develop will ( try to ) start.
-Copy and paste here the whole text that is displayed in the bottom part of Dependency Walker.

You can also download the previous version of GD : if you don’t want an installer or if you want to keep the latest version of GD installed. ), may be it will work better. ( Post also a message if this version works but not the latest one )

Tried running as admin, but nothing happened either.

My graphics card is an AMD 5770

Downloaded the one without the installer (so it wasn’t installed to program files)

Log is here:

Thanks for the logs.

For the second log, which version of Game Develop it is ? ( The latest or the version 1.5.9955 ? ). Was Game Develop successfully launched ?
If GD failed to launch, try :

-To remove GDEditor.exe.Manifest, located in Game Develop folder. Then launch Game Develop. Try with both the with/without installer version and make a log with Dependency Walker if both failed.
-The 1.5.9955 version :

In all case, it seems better to launch Game Develop and Dependency Walker as admin.

You shouldn’t need to use admin for anything other than changing windows settings, that is why UAC was designed and why users are no longer by default admin, would be best if you develop it on the basis not to run it as admin.

GD uses admin right because it uses a temporary folder to compile a games. This folder’s path is “C:/Program Files/Compil Games/Game Develop/Compil/”, that’s why GD need admin rights, I think.
But, you can change this folder in GD’s preferences. :wink:

I must admit that I’ve never really tested GD on an non admin account. But I’ve always found the implementation of admin/non admin rights poorly done on Windows, compared on Linux ( Sometimes, Windows will tell you you have to be admin, e.g. when installing a software, whereas Linux offers you to type your admin password so as to continue your work. ).
I’ll try to take a look at this.

Note that I said you to run GD as admin so as to be sure your problem does not come from insufficient rights.

If your problem is not solved, try to use the version released tonight ( Simply download again Game Develop ), as it fixes a similar problem on Windows XP.
The problem can also come from your video card drivers, even if they are recent, some ATI Radeon users suffers from problems with OpenGL ( and even if I have myself no problem with a Radeon HD 5870 ). You can try to roll back to older drivers.