Gdevelop 5 Beta 91 Windows - Won't start and show an Error

Hi, some minutes ago have opened Gdevelop 5 Beta 89 and have waited to download the update.
Quitted Gdevelop after the download and tried to open the new version Gdevelop Beta 91 but unfortunately won’t start and show the error window below.

Small note: I’ve tried to download it manually and reinstall it but happen the same thing :frowning:

My OS is Windows 8.0 Pro 64-bit and this is the the error window each time i try to open Gdevelop


Hope @4ian or others contributors like @Bouh can solve it.

Thanks in advance

Same error on Windows 8.1 laptop (also 64 bit)

Some GDevelop contributors had that error in the development version. I had it too and fixed it by running npm install (on the dev version).

Can you list the steps for that please? Or a link containing the info if available would work too.

I’m sure it isn’t super complicated and I’ve used npm install while playing around with JS for learning purposes, but don’t think I’ve used it for anything related to GD and I don’t know exactly what needs to be typed or where.

Edit: Is this the info? GDevelop/ at master · 4ian/GDevelop · GitHub

Yes, exactly. I don’t see how modules would be missing on the release tho.

Thank you!

Yeah, that’s really weird. Seems it should be looked into and fixed properly though as those with little or no programming experience aren’t likely to understand how to use the npm install fix and they may not even have Node.js or Git set up on their machines.

I don’t use the dev version of GD either.

Beta 91 has an updated version of Electron.
This should not happen because Electron is bundled with the app.

Can you confirm:

  • did you try to uninstall and reinstall GDevelop Beta 91, using the download link from the website (I just fixed it today).
  • how you are launching GDevelop?
  • do you have Electron somehow installed itself on your system?

Seems to be fixed on my end now.

I had to completely delete all of the program files (except projects, of course) under …AppData/Local… then do a fresh install from the link you just updated. It seems that the auto-updater isn’t auto updating certain files such as electron.asar - their ‘last modified’ dates were stuck at the 4th of March while others had yesterday/today’s date.

To answer the other questions; Usually the desktop shortcut or start menu, and no, I only have whatever comes with GD with regard to bundled programs.

Thanks! :slight_smile:

The solution seem a clean install.

This file is not used anymore, normal if this wasn’t updated, because it’s now useless :slight_smile:
For technical details

Makes sense.

Based on the error, is it possible the program is still trying to run it somewhere though?

Edit: I don’t really understand all the technical details, tbh, but thanks anyway. :sweat_smile:

@4ian I confirm what have writed @Phenomena ! The upgrade from 89 to 91 broke the installation so it’s correct to uninstall all and reinstall the upgrade 91 manually :+1:


This topic was automatically closed after 46 hours. New replies are no longer allowed.