Gdevelop crashing upon new project creation

This video shows my issue in action, as well as a terminal. I have no clue what it means or how to fix it. Please help.

And if you launch GDevelop with ?

Just wanted to write about the same issue and found this one here.

The freeze happens when a scene is opened. Either after creating a new project or after opening a scene from an existing project.
I have run GD via “./” and get the same output as ShobieShy in the YT video. Tried to run it with the debugger but it doesn’t let me enter the “bt” command since the application doesn’t “crash” but just freezes.

For me it happend in the self compiled version from trunk (downloaded 15.01.2017).
With the version from the repository everything is ok.

My system:
Linux Mint 17.3 (64Bit)
Nvidia GTX 760 (Driver version 367.57)

It’s very likely caused by the proprietary NVIDIA driver I think.

Was there any wx update recently or could this be related to the new sfml 2.4.1 update?
The old version of GD is still running nicely here.

It may be related to the SFML update but I think they fixed something that looks similar for the next update

I did some testing on another pc with an ATI Radeon HD 3450 GPU.
It freezes too.
Maybe this is a general Linux issue. Does it run on your system Victor?

Obviously yes, I would have pushed this change otherwise. I have an Intel + NVIDIA Optimus computer with the free drivers.

Repository version works? I may just have to do that once I get unrestricted internet back. Good to know.

EDIT: Also I run an i5 3570k and a GTX 1080 on 375.26 proprietary drivers.

experiencing this on windows 10 as well just curious if this due to my hardware I’m trying to run this on an older dell inspiron n5030 notebook probably an obvious answer but I appreciate any responses thank you