GDevelop doesn´t install properly

Hi i tried to get the newest Version of G-Dev for my Windows 10 PC because my friend downloaded it and he had another version.
So because my version wasnt updating I deleted all G-Dev files (everything but my games) but now when i download it and execute it the installing bar gets stuck half-way ,does anyone know how to fix this?

Thanks for the help

Maybe the previous version was not uninstalled properly and left a key in the registry and this is why the installer get stuck because it is trying to uninstall it but can’t find it.

If this is the case, you may need to edit the registry manually or use a 3rd party uninstaller if you don’t know how.

For example one uninstaller is Revo Uninstaller but you can find many more:

If you can’t get it solved, you don’t actually need to install it, you can use a packaging tool like 7Zip to open the installer and extract GD from the installer manually. Not sure why GD does not include one without installer and call it “portable”.

Many people had this issue. I think reinstalling the previous version and uninstalling again helped. I suppose it was, like for everyone else, beta 89.

Follow this process:

1 Like