Gdevelop for later versions of Ubuntu?

I followed the simple instructions for installing GDevelop for Debian-based systems, but I received a message stating that the package was not found. I seem to remember reading a post that it at least works up to a 13.10 release? Does anyone have a compiled version for later OS’s (such as a .deb)? I have Xubuntu 14.10. I also tried to compile from source to no avail (after installing all of the dependencies, one component did not seem to align itself properly prior to building). I appreciate any thoughts on the matter.

In the meantime, I’m running the Windows version via Wine, but I imagine the native linux program to have enhanced formatting and performance.

Everything you need is on the main website :
You have the instructions to add the PPA to your Ubuntu and then install gdevelop (it’s available for 14.04 and 14.10).

I receive the error message “Unable to locate package gdevelop” despite the terminal appearing to successfully add the PPA and update. Could it just be that because I have Xubuntu, package organization is a little different?

I just realized I posted in the GDevApp forum, sorry.

No, I have Xubuntu and I can get GDevelop. Do you have (X)Ubuntu 15.04 or 14.10 ?

I am actually just now upgrading to 15.04 as I post this

GDevelop is not available on 15.04 now (might change soon).

ok, I’ll continue using Wine for now. Thank you for your help!

I’ll post an answer here to say when the 15.04 will be ready. :wink:

To be honest, I’m getting this issue to

Lubuntu, 14.10

any ideas ?



No, it works on my Xubuntu…

EDIT : You need a 64 bits Linux to run GDevelop, that might be the problem. :wink:

It’s now available for Ubuntu 15.04. :wink: (64 bits only)

oh, ok. That makes sense now. I remember finding a section of .deb packages that were 64-bit. My system is indeed a 32-bit one. Oh well. Good to know :stuck_out_tongue:

ah, 64b, okay - missed that bit.

so now I’m running a 64b Ubuntu ( 14:04 ) and I’m getting

gdevelop : Depends: libwxbase3.0-0 (>= 3.0.0) but it is not installable
Depends: libwxgtk3.0-0 (>= 3.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

kinda one step forward, two steps back :slight_smile:

should I go to Ubuntu 15 or … ?

many thanks


Is the “Universe” repository enabled ? Because these packages should be installable…
(Here is a proof that these packages exist :

did a complete fresh installation, obv something screwy on my side.

is installed, is working - just gotta suss how to make the next candy crush and retire to the bahamas now … :slight_smile:

thanks for the help, see you on the board


You just had to enable the “universe” repository in the “Source & software” settings. :nerd: