GDevelop Linux

Here is the last version of GD compiled for linux :

Launching it

Download and uncompress the archive in your personal folder. Go then in the “release” folder.
To launch the program, you have to give to “GDEditor” and “Start Game Develop” execution right. ( Usually, right click on the files, and go in Properties ).

Known problems :

-Keyboard is unusable in scene editor.
-Compilation does not work.
-You have probably to remove so as to be able to launch the software ( see below ).

The program does not start

First, try to remove the file and relaunch “Start Game Develop”, as the freetype version provided with GD can be in conflict with the version of your system.

If the problem persist, launch a terminal, type “cd folderwhereislocatedGD” and then “./Start Game Develop”.
Paste then the error that is displayed in the terminal.

I have this error in the terminal:

DarkHog@SkyNet:/mnt/temp/GD/release> "./Start Game Develop" ./GDEditor: symbol lookup error: /usr/lib/ undefined symbol: FT_Library_SetLcdFilter

I am OpenSuSE user, if it is important.

//EDIT: Oh, if it would be OSS I’d get sources and compile GD perfectly for my system.

I did it (and rather renamed added to GD release for and finally ran GD, but It crashes often with Access Violation/ Out of Memory errors, and can’t use it. I know that its early stage of GD linux, but I don’t thnk that application which crashes all the time will be useful for someone.

That is why it is not publicy released. :wink:
I have also some random crashs when opening a window containing field of text. If you want, you can :

-launch a terminal,
-go in the debug folder instead of the release folder,
-type “export LD_LIBRARY_PATH=./:$LD_LIBRARY_PATH” and then “gdb GDEditor”.
-When the Gnu Debugger is launched, type “r” so as to launch the debug version of Game Develop ( which will be pretty slow ).

When it freeze, a crash has probably occured. Click on the terminal window, and type “bt” so as to obtain useful information you can paste here so as to help me identifying the bug.
Note that when you use the debug version, if there is any error window, try click on “continue”.

Seems the download isn’t there any more and it would be old anyway, any chance of a newer download?

Here is a newer version of Linux :

As previously :

Context menu for adding events seems to be not working : Use the ribbon instead.

When will compilation and the keyboard issues be solved?

You may also want to update your first post with the newer link and mention it needs libgdl to run. Although i have libgdl packages installed it still won’t run saying i don’t have it?

Here is the link : I’m still working on the issue without finding solutions. Note that everything is included so as to launch the program : use the file “Start Game Develop”.

What’s changed in this version? Seems to mean the version number is lower on that link?

This version still won’t launch either - check the bugs forum for my post.

Link to the latest version :

Thanks will be giving it a go when i have a chance.

You may want to update the first post with all relevant info and the new link.

I have a problem when I try install Game Develop in Ubuntu 11.04 (I’m using Wine for run the Windows version), I run “Start Game Develop” in a terminal and Game Develop Send it to me:

Deleted stale lock file ‘/home/wizard/GDEditor-wizard’
Instantly it create “GDEditor-wizard” file in /home/wizard/
Game Develop Installer is in /home/wizard/Descargas/GameDevelop/release/

And creates a windows back with the guide for send my problem, then nothing happens.

The terminal write it: OnInitCalled CommandLineParsed CwdSetted ImageHandlersInit Config file setted Language loaded Single instance checked GDL checked Help file setted


I’ve compiled Game Develop on Ubuntu 11.04 :
( Remove yourhomedirectory/.Game Develop/options.cfg file to be sure that ribbon is properly displayed ).

Please note that Video Object and particle engine extensions are not available. Moreover, there are still problems making scene editor not usable and and the compilation does not work properly on Linux.

Ohhh yes! It work perfectly. Now doesn’t send the error message.
Yes, you are right, the video of scene object doesn’t work very good. I have other problem… It doesn’t open .png files? I have to see wich files it can open. And a question: How can I change the FPS, layers, etc.? Before, in the Windows version I maximize and then minimize the object window (at right) and these windows (FPS, layers) appear, but now it doesn’t happen, anyway I could never change the FPS, maybe under WINE don’t work these window.

Is there a way to run it on 64bit?

32 bits program works on 64 bits OS usually, but in this case you need to get the 32 bit version of libGLEW and put the file in the directory of GD. Maybe searching on the web will lead you to a link to the 32 bit version of libglew. I know a french user had the same problem, I will give you the solution he found as soon as possible.

Thanks, do you plan to support the Linux version a bit more rather than the odd version every couple months?

A 32 bit version of libGlew can be found here : under the name of
I downloaded it and extracted the file for you, so you just have to download this : (277 KB)
Put this file in Game Develop directory and it should work.

If this linux version works without strange crashs, I will maybe release a linux version of GD each time a new version is available. But I will probably support only a few distro ( The latest release of Ubuntu typically ) and there are still some problems which have to be corrected in order to make the linux version fully usable.

That file made it run thank you, minor bug found so far:

When opening a tab inside the application, say i double click on scenes, the tiny cross doesn’t close the window.

Supporing Ubuntu would be fine since it’s the most popular distro.