GDevelop not seeing running preview

So, I am using the latest version of gdevelop and a few days ago I realized that the preview button doesn’t change to update when a preview is running and I later realized that I cannot use the debugger because no matter how many previews I have open, it always says that no preview is running. This happened after I upgraded from windows 10 to windows 11 but I am not completely sure that windows is the problem since I also updated the BIOS before upgrading. This is a problem since I normally use the debugger a lot. Is there some fix? Is a it problem with the engine or something else?

Hello, MKDeveloper

Blocking Gdevelop through the firewall causes exactly this problem you are having.

To use the debugger it is not necessary to be connected to the internet, but Gdevelop cannot be blocked by the firewall. Perhaps because you’ve upgraded to Windows 11 your firewall settings have changed?

I checked and gdevelop is not being blocked by windows firewall or the firewall of avast antivirus. I don’t know if it helps, but I forgot to mention that I also tried going back to previous versions and it still doesn’t work.

So, I’m sorry but I don’t know how to help. :pensive: The only way I know to reproduce the exact same problem is blocking through firewall. Here it has been working normally, but I use Linux Mint. I hope someone else here on the forum can help you.

Hi @MKDeveloper,
I don’t think we changed this recently.
Would you be able to open the developer tools (Ctrl + Shift + i) after trying to launch a preview and take a screenshot of the console content?

This is about five seconds after launching the preview.

Unfortunately I see no issue in the console and there is no error as well.
I’ll think about it and get back to you