Gdevelop - Project and Extension errors

Hello, Gdevelop team
We at TimeSpace are addressing some issues we found in our Gdevelop game projects, please take a look at the below screenshots and captions for the issue.

  1. Tween extension not working or showing -
    In the below screenshot, as you can see, the preview is completely blank, and when I took a look at the events. I can see the tween behaviour action is red out (error).
    I checked the object with tween behaviour, but it says “Unknown behaviour”.


Blank preview

Shows Behaviour is unknown

Events actions are red in error

  1. Object or layer effect error - As you can see in the screenshot below, the actions in the enable effect are Yellowed with the Caution icon, I opened the object with the effect, and it properly shows the effect. Not sure why but this also makes the preview of the game not visible, only the blank preview.


The effect is properly visible in the object properties

Issue or error in the action of the enable effect

  1. Text actions - There are also some issues with the Text actions, but when I click on the actions to open, it shows the properties and parameters just fine. This also makes the game preview blank.


Preview of the game, with the actions that are yellowed out.

We also checked the Debugger tools to preview the game look for issue, but it is blank. We are not sure where is the issue. Maybe in the Gdevelop version.

So, we have share the detailed issues in points along with the screenshot, please go through it and let us know the issue, If there is the issue in the Gdevelop. We hope for a quick fix in the coming updates.

This is very important for us, as we are regularly and constantly working on New updates for our games on App stores, and releasing new games. This issue is like an pause for us.

So, We hope it will be fixed ASAP.

Thank you!

This means exactly what it says in the errors, your events cannot find the tween behavior on your object, and it appears whatever behavior you have on your object is invalid.

This could be from project corruption, but regardless of the source the only solution is likely to remove the invalid behavior from your object and readd the valid one. You would need to do this for each object with the behavior amd likely need to delete and readd the tween event conditions or actions.

If the errors are still there, see if you can create a new empty test project, add a single object, then add the tween behavior. If it works there without error, it is your project that is the issue. If it etrors there as well, something is corrupt with your install of GDevelop. Hopefully this at least gets you closer to a solution on this issue. I cannot provide guidance on the rest.

Just to clarify, please note this is an open source engine, there is no guarantee of fixes nor support, and changes are frequent. There are per-instance/one-off paid consulting support options available from the company, but that still doesn’t guarantee a fix, just a consultation.

I’m just adding clarification here because your verbiage above makes it sound like you are expecting someone to specifically modify the engine or your project and/or the engine code to solve your errors and while that is possible I want to make sure you understand that isn’t guaranteed nor should it be expected.

Hey! We tried Uninstalling the Gdevelop and then Reinstalling it from the official website.

Now the Tween extension behavior is automatically reds or missing behavior.
But now one issue is there,
The preview game is not working, now even the preview window is not appearing, No matter how many times I click, I even tried the LAN preview, debugger, and other previews.

but the preview window is not appearing, you can check the the below gif
GdevelopNewversion installednowporevew
you can see in the task bar there is no additional preview window is open.

We are not sounding like anything, we just found the issues and we posted it.
We have been working on the Gdevelop for 2years for our Games, we never had any issues with features or editors like the bugs. We just faced it now and collected the issues and posted them in here So that the community and Gdevelop can be aware of the these issues.

We are also actively developing and updating the games for the Google Play Store, so we expect a fix soon. And we know the Gdevelop is an Open source engine.

Anyway, the issues seem to be fixed, now The preview is not showing up no matter how many times we try to do it.