Gdevelop wont run/launch

I downloaded gdevelop and tried to launch it but nothing happened, i tried to check if it would run in the background, it would appear in the background for a second then it disappears, it worked on my old laptop but now idk why it wont run, i tried uninstalling and reinstalling twice, and i tried launching the installer as an administrator and i tried the same with gdevelop itself, but nothing changed, can anyone help?

Can you confirm the version of GDevelop and your operating system?
The install goes fine?
Did you check in the process manager if GDevelop is running?

1 Like

its the latest version, i just downloaded it yesterday from the main website, i dont know a lot about my pc i only know that its a lot better than the old one and it should work on it,im going to check the process manager thing right now.
Edit: i just checked the process manager and like i said, nothing, when i try to open gdevelop it appears in the background for a second then it disappears.

Does this work: ?

Do you have a 64bit system?

yes i do, why? im typing this because post has to be 20 characters long

my internet us bad, im not going to wait 10 hours everytime i want to use gdevelop