Getting issues!

I opened gdevelop , did some work and then when I opened it again (after closing) it did not worked

This message appears!
It’s not not that this is the first time, This has happened many times to me. I always reinstalled Gdevelop but I want a solution to this problem.
One more thing is that when I preview the project it takes too long for the pop up window to appear even if there is 1 object in the scene.
Please provide solutions for these problems . Are there chances that this is due to my pc ? :thinking:

I’m pretty sure this happens when you try to open GDevelop while it’s being updated and all the files are being deleted and reupdated, because this happened to me earlier when GDevelop was in the middle of installing the newest version. I just waited a few seconds and it was working fine again. When this pops up are you not able to use GDevelop at all even after waiting a few minutes? Or do you just immediately uninstall and reinstall (or shut off your computer/mess with the program files)?

Also in terms of the preview being slow it looks like you might be using a relatively outdated version of Windows, what windows version are you running?

When I close the app after 2 seconds a pop up appears , which shows
verifying installer … Something like that
. Sometimes even after the the pop up I could open Gdevelop and so sometimes not. After this pop up the the next pop up appears (image is above)Then when I click again on the app it does not open as mentioned above

Yes, I wait for some time and the reinstall it.
I am using windows 7

Uinstall gdevelop then open any folder and type in address bar %appdata%
And hit enter
From here remove gdevelop 5 folder
Now download and install gdvelop again

This solved my issue when gdevelop was notifying me about update and said it will update after i close gdevelop but it never updated itself

Also i was on windows 7 until like 2 months ago
And i was using gdevelop for almost a year
So i highly doubt it can have anything to do with windows 7 (talking about your issue not mine since mine happen on windows 10)

I also get the update about Gdevelop that says new update is available… Click to… Something like that after closing Gdevelop.
As u said that type %appdata% … I have done this multiple times earlier but It’s still creating a problem.

Did you also try

Install or move installation to another folder
Like C:\Gdevelop would be enough

Run gdevelop as administrator?

Install gdevelop from here Release 5.2.168 · 4ian/GDevelop · GitHub

Just curious are you on Windows 7 32bit or 64bit?

I tried to download it in C drive , E drive and even D drive but nothing happened
I haven’t run it as administrator I will try…
I will also download from the link you gave❤️

I use 64 bit(20 char)

I am pretty sure it is windows related issue not windows 7 because i would have same problems when i was using windows 7
And i never had
Tell me results and if it won’t help ill find few other things to try out

I downloaded from the link but It’s very laggy, the preview window hangs for do long.
The pop up window problem has not come till yet and would not come now even if I download Gdevelop from website because it comes automatically after few days, minutes…

Did you try creating new project and see if it behaves the same way?

Yes, when I preview the examples of Gdevelop they work well but when I open my project the preview window freezes

That would indicate issue with your project

I don’t think so because it with every project I create…

Then why examples work correctly?

Sorry i am not good with figuring preview issues
That is something someone else will need to help you with

1 Like

BTW you can try to download older version
Just click on number Releases · 4ian/GDevelop · GitHub
And then let it update itself to see if it works

I just tested more examples, now they are also not working… :persevere:

I installed Gdevelop from the official website but the preview window freezes for too long and by chance of the scene is loaded then windows says it has stopped responding…
And then it showed this-

This msg was shown first time, the preview window stopped may times but this showed for the first time.

Today again when I started Gdevelop it showed new update is available and will automatically update itself on closing Gdevelop but when I closed it and again re opened it , it did not opened and shows this again