Having issues with version 127

Hi guys. The new update broke some functionalities of my game. I didn’t test thoroughly because I immediately came back to previous versions (only 5.0.122 worked as it should). Here is what I noticed:

  1. Im making a point and click game, so I move my player with pathfinding behaviour and I limit the walkable area with variables and coordinates. With the new version, when the player arrives to destinations it weirdly jumps, like shaking and uses the wrong direction (I flip the animations depending on the direction it should be facing). Same thing happens when I play any animation, it’s not respecting the “flip animation” event.
  2. hovering over objects should show a text with the object’s name and hide it when stop hovering. With the new version, it shows the name correctly but never hides it, even if I’m not hovering. These are the events:
  3. The player is changing rooms without meeting all the conditions to do so (eg. it should leaves a scene only if a variable values is X, but it’s always leaving even with the wrong variable value.)

Anyway, I doubt this is gonna be useful without enough details. But I have a long way before I finish my game, I wonder if it’s too risky to continue with the 5.0.122 version and never update until I finish. I’m very hesitant to make any big changes (just to get it to work with the 127 version) , my game is big and has variables, external events and functions connected everywhere. It was working smoothly before the update :confounded: :cry:. Any advice would be appreciated.

Hello there,
Sorry to hear you’re having trouble with the new version (versions?).
The only recent (potentially breaking) change is the timers, I think. Please read the related announcement if you haven’t done so yet.
If your new issues aren’t related to that, I think we can consider them as bugs.
Once the bugs have been identified, the dev team will take care of them, but for that, they need to reproduce the issue on their side.
If you’re able to reproduce any of these issues in a dummy project (or an example project with minimal changes), please share it with us.
In the meantime, feel free to keep working with the latest functional version you find.

Can you confirm that you tried version 5.0.123 and that the problems you mention are there too?

1 Like

Thanks Gruk. I only downloaded and tested the versions 1.0.125 and 5.0.122 because they were the only ones available:

I just realised that the other versions are in github.
I’ll try to reproduce the issues in a simpler project. Thanks!

That’s not an official GDevelop distribution source, please only download GDevelop from the official website at https://gdevelop.io or GitHub page at https://GitHub.com/4ian/GDevelop. Otherwise, you get the risk of getting an outdated, broken, or infested with viruses version of the software.


yeah, my bad… didnt notice it was not the official one. Made a quick look for “gdevelop previous versions” and came first in the search.

Myself, and another guy I found on Reddit are having an issue with 127. When we add new scene variables, we can’t change them with clicks and key presses.

The text object always returns “0” to the string, no matter how many times you press “C”. Someone on Reddit said they couldn’t duplicate it. I don’t understand. This occurs for us even in a brand new project. To be clear, old conditions that were previously created to change variables on input are still functional, yet new ones are not. If it turns out it’s not a “for everyone” issue, I suppose I’ll rollback versions.

@WoodBooger While there may be other things going on, “WeaponLvl” isn’t a valid variable name, and is different than WeaponLvl.

No quotes allowed in variable names.

Here it is with the corrected variable name:

Here’s a preview with these events: https://game-previews.gdevelop-app.com/1644274546507-867319/index.html


Correct you are. I figured it would have to be something like that. I think I need some coffee.

1 Like