(Help!) Problem with mobile app (iOS) - Project closes when opening asset store in project

Hi, I posted this on January 15, but the problem still exists. The problem is with mobile version of GDevelop on iOS. Do you have any ideas how to fix this? Here is problem: when I create or edit object and want to add sprite I’m going to object properties, choosing option „Add sprite” → „Choose from asset store” and then asset store opens. And now, almost every time when I try to type something in search bar or click on chosen asset the whole project closes down (all tabs closes, scene, event sheet etc.) only home tab left.

I’m on GDevelop mobile iOS iPhone 13 Pro
Here is my version

To reproduce this error you just need to open project on your phone with iOS and

  1. Create new sprite
  2. Click „add an animation” and then „add a sprite” and select „choose from asset store”
  3. And when asset store window opens here are some examples when this error or bug happens. The project can close when:
    a) asset store just opens
    b) you type something in search bar
    c) you click on asset category for example 16x16 characters etc.
    d) you click on any asset or select it

The interesting thing is that this happen in most cases (9/10) but not always. Sometimes I can select 2-3 sprites and then everything closes and sometimes when I just click „choose from asset store”.

However when I’m in home tab and search assets from there (it’s the shop icon, third from left in the bottom) I can add whatever I want by clicking on „Add this asset to the project” and selecting my scene without any errors.

Do you have any ideas how to fix it?

Hi @Piotrek,
Thank you for taking the time to report this issue!

I couldn’t reproduce the bug though (thanks for the step) with an iPhone XS.
Could you record your screen while reproducing the bug and send it over?

Hi, here it is, it shows exactly how this error works. On this video error happened when I add third sprite. But sometimes it occurs on first time.

https://youtube.com/shorts/iiHg8PoAyY8?si=oOchXvStgip53iaA

Hi, do you have any ideas what can cause it or how to fix this because this bug still exists. For now iPhone is my only tool to code so it is very important to me. Thanks in advance!