Hi, I'm having a problem with the export

When I’m trying to export the game is getting out of GDevelop. It doesn’t finish exporting the game. The third(Build and download) step of exporting the game never reaches its goal. I have the latest updates, the game is running perfectly in the preview, but it doesn’t build the game. If anyone has a solution or a fix or its a problem with GDevelop that needs fixing, please help.

Thank you!

:wave: Hi and welcome here :slight_smile:
Have you tried to check the existing builds, see if the download is available?

Do you get an error? If so, what does it say?

Hi, Gruk! Thank you for answering. Now, I’ve tried to build and HTML 5 and the directory in what I’m trying to create the game looks like this:

I’m trying to build my games manually, because through GDevelop when is getting to the final step crashes by closing. When I restart GDevelop it says I have the same two builds. Practically, GDevelop is telling me that I never used those two builds.

If you have any idea what’s the problem, please help :smiley:
I like using GDevelop, but Ican’t build my games with it and I don’t know why. I get all the steps right and it is not working.

Until you find a solution, I will try to solve this if I can :smiley: Thank you!

Hi, Gruk! Thank you for answering. This what I get when I’m trying to export an HTML5 file and Desktop file:

In both cases, there is no file. Normally, it should be some js files in the desktop case and some index.html in html case. What can I say: help, help, help :smiley:

Sorry,it only lets me to put only one photo per message. This is what’s next:

That is strange.
You can try:

  • updating. You seem to be running an older version.
  • logging out and in again. In File/My Profile.
  • running GDevelop as admin. Perhaps a permission issue.

Hi, Gruk! Thank you for answering! I used to run an older version, but I made an upgrade recently. After the upgrade it started to have issues with it. I think it’s a big issue the fact that I can’t build my game. The game worked perfectly in preview. Worked, because deleted everything, but kept my files intact so I can build another one. I will build a shorter version to see if GDevelop can manage a smaller game. I’m taking my big game and make in it a three part franchise :smiley:
The game itself was big, like 3.80 GB. Maybe this is an issue. I don’t know. Now, I’m building my game again really fast and see if its working. The big issue is that the engine as you could see in the photos doesn’t build anything. It’s just empty folder.

If someone from GDevelop can solve the issue it would be quite amazing.

Thank you very much for your time and support! You’ve been fantastic. :smiley:

You definitely will not be able to use the online build service if your game was 3.8gb. it maxes out around 200-250mb per build, and even that depends on your upload speeds. If it worked before it should not have, and you were going past the free limits (and even the paid limits) for the online build system.

That said, local builds shouldn’t be a problem, though. I just tested a local html5 export with a bunch of videos totaling 4gb and it exported okay.

I would say ensure you don’t have anything that will be game breaking (a lot of assets with source sizes over 2000x2000 for desktops. 1000x1000 for older mobiles, etc). But otherwise I’m not sure what may be going on.

Thank you for answering Silver-Streak! Sorry, I didn’t know there is a limit. Now, I understand why GDevelop crashed when I tried to export. I will take your advice and let’s hope it all going to be amazing. Thank you very much for your time and support! :smiley:

1 Like