HTML5 previews not working in Linux Mint

HI, new user here. I have GDevelop installed on Linux Mint 18.1 (64 bit) and am working on the tutorials to learn the program. When I run Previews of HTML5 games, they open a blank browser window (Firefox50.1.0) Previews of “Native” games seem to work. Is this an incompatibility with Linux Mint or am I doing something wrong? I assumed that since Mint is built around Ubuntu that the Ubuntu version of GDevelop would work. Thanks for any suggestions.

Can you show us the message displayed by the developer console of your webbrowser? (which one by the way?)

There isn’t any error message. I’m using Firefox 50.1.0. The browser opens a “localhost” address with a blank page when I try to run any of the sample games.

For instance previews of these games run as HTML5:
“Web Shoot’em Up” game produces a totally black page , but I can hear sounds (explosions).
“Advanced Tutorial” (Tanks) previews a gray field in the center of a black page…and no sound.
“Web Soldier” previews a black page, no sound.
“Platformer” looks similar to Advanced Tutorial, but the center of the page is pale blue.
“Angry Peas” previews as a gray page with small horizontal black strip on top and bottom. The preview works when run as “Native”.

When I try to preview my work on the tutorials, I get similar results.

BTW, I Windows Vista installed on a different partition of my hard drive and previews in the Windows version of GDevelop work properly there. Since support for Vista is soon to be discontinued, I’m trying out Linux Mint as an alternative. Thanks for any suggestions.

This strange result looks like a problem with webgl on Firefox, do you have special graphics drivers installed? or the free ones?

I installed the nvidia-304 (recommended) drivers.

Operating System:Linux-x86_64
NVIDIA Driver Version: 304.134-0ubuntu0.16.04.1
NVIDIA legacy binary driver version 304.134

My alternate option is:
xserver-xorg-video-nouveau (open source)
X-Org X server - Nouveau display driver

You should consider trying without them.

Well that didn’t work out. I uninstalled the nvidia drivers and reverted to the open source alternative that was originally packaged with Mint. After re-booting, I opened up GDevelop and tried a preview. The preview caused the computer to freeze and I had to reboot. This happened twice. I had had this problem occasionally when opening Firefox prior to installing the nvidia drivers. On the third reboot, GDevelop won’t even open.

I’ve reinstalled the nvidia drivers and rebooted, but GDevelop still won’t open. I’ll try to uninstall and re-install it. If/when I get GDevelop to open, do you think a different browser like Chrome would work?

GDevelop may have problems on lastest Ubuntu and possibly Mint when opening a scene for editing (however, this is not related to the original problem you have). With the free drivers, did it crash when opening a scene for editing?

No, I believe was the act of opening the browser (to preview the game) that caused the crash. I had this problem a few times with Firefox prior to ever installing GDevelop. Updating to the nvidia drivers seemed to cure the issues with Firefox.

The good news is that I installed Opera as my default browser, installed the nvidia drivers, did a fresh install of GDevelop, and the previews seem to be working fine. Problem solved, except that I dislike Opera. Is there any option in GDevelop to select a browser, or must it use the system default?

Thanks for the help.

Unfortunately, GDevelop only uses the system browser now. But, I think we can improve this in the future.