Intel XDK Android Crosswalk compile problem

Updated both gdevelop and intel XDK last week and am unable to compile a working game for my android tablet now. I am using cordiva 7 as suggested for compatability but to no avail. All i get is a blank white screen. No loading what so ever. Worked perfect up untill the updates. :confused: has anyone else had this problem and been able to correct it? I am at a COMPLETE standstill.

An error message ?

Did another update with XDK last night and a quick cordova compile… no it took a lot longer than usual. Used the arm version on my tablet. Now I am getting a message than the “program unfortunately stopped running” on the tablet. Nothing during compile. Thank you for your response.

I’ve had the same issue, if you go to the emulation tab in intel xdk and lick on the bug button you should see the error report. I get an error with the pixi.js.13 but it could be unrelated to the white screen.

You hide the file name, how can we find what’s wrong ?

That error is just from a missing image, I posted that up so Traun could see how to check the error logs in intel xdk.

Going into the console tab I only get this error message. Funny thing is I am making a space sim type game and do not call for any bunny.png. It also appears that it is trying to get this png on line.

This looks fishy to me. I have nothing in my Gdevelop code to pull this image from pixijs.com
when I look in my resourses tab frames>documents>images thereit is!!! WTF. :frowning:

.js… Javascript? could this be a type of virus?

Copied from the console log
Forcing fullscreen for Intel XDK. runtimegame.js:57
Pixi.js v2.2.3 - webGL pixijs.com/ :heart::heart::heart: pixi.js:12
Failed to load resource: the server responded with a status of 404 (Not Found) 127.0.0.1:58889/http-services/em … erapp//C/U…ir/dd064cd4-572e-4f60-a73f-3773451b24ad/platforms/android/assets/bunny.png

It’s not a bug, Pixi tries to load an image “bunny.png” by default (don’t know why) but it should work even with this error.
Anyway, it’s likely to be an error related with the Intel XDK. (If it works under a webbrowser, but not on an Crosswalk app, it’s not a GDevelop’s bug).

Ok… Ok. Not a Gdevelop bug understood. But a Pixi problem non the less. Mine with 12 and the other with 13. How to fix?

If you try to run the game in g develop with a missing pic resourse it will crash and tell you your error. this is something else completely. Is there a way to downgrade the Pixi.js version? Worked once apon a time. The only reason I am asking on this community is because this is the recommended way of compiling gdev for android.

Thanks for all the feedback

It was the same version before (and the “bunny.png” error doesn’t cause the game to crash).
Again, try to launch the preview of your game : if it works, it’s not a pixi.js problem either.

Sorry to waste your time. I found the problem… Karma. I fail again and give up. :frowning:

Does it work when previewing inside a webbrowser ?
Have you tried to downgrade the Intel XDK ?

Hi! I had some similar problems, but I’ll try to explain the steps that worked for me( I am using the last xdk update ):

-1) From GDEVELOP export with xdk option;
-2) Open the xdk project generated from GDEVELOP. It will prompt you to update to cordova or not…(choose update to cordova);
-3) I did not changed any options, and in the build section choose cordova android crosswalk build;
-4) It worked here.

I am using Linux.

You must export using Intel XDK option (and not the traditional export for a website). Did you do this, as ricardograca suggested? :slight_smile:

I compile using the ios xdk option. Then in xdk i use update to cordova and compile using android crosswalk. I do i down grade xdk version. is there a repository for older versions?

Can you send us your project ?

I had the same issue of a white screen with older version of xdk 1826 too. If I exported the project as a website and run it from google drive everything worked okay on any mobile device I tested. I was able to build an apk on the adobe PhoneGap build server that works without issue on every device as well.

Found my old download of xdk 1621 and it works again!!! The problem is with the xdk update! I could not of figured this out without the help of you guys. When I have a good working copy of my game I will be happy to share. Thanks again… I did almost give up there.