iOS app frustrating and totally useless due to a horrible bug

Hi guys, so there’s an extremely devastating bug that keeps happening in the Gdevelop app that I’m running on my iPad Pro 2020. The character sprite jumps, or more like jerks endlessly no matter what setting I change, or if I add the ‘De/activate moving the mouse curser with touches’ action. As soon as the ‘Platformer Character’ behavior is added to the sprite, it starts rapidly shaking and there IS no way to stop it, making this app completely useless and extremely frustrating. The same file works fine when I open it on my computer which I don’t want to use because that’s what I do all day at work. It would definitely be awesome to use the iPad for making games but this bug is just so brutal I don’t know what to do. Any suggestions? Anyone else running into this on iOS?

I am trying to use it on my iPad but so far completely un-usable on multiple accounts. The fact that you can’t re-order events by dragging them is a game-breaker for me. Especially if you try to use the interface with a mouse on the iPad you find multiple bugs.

Seems like a fully functioning game engine in an app is just too hard to get right. I was so excited about it too. Although maybe someone in the Gdevelop team will see our posts and address these issues.

I’ve just created a new bug report topic since i’ve found a few issues both when using mouse and keyboard on mobile and using the touch interface on the ipad. Both in-app and in-browser. Hopefully someone will take note.

1 Like

Is your character animated?

Frames should either:

  • be the same size when default collision mask is used
  • or share the same custom collision and origin point

Otherwise, while the animation is played:

  • the character may have a collision mask which goes down
  • so the platformer behavior moves it up out of the floor
  • the collision mask go back up in the other frame of the animation
  • so the platformer behavior makes the character fall
  • and it loops

The character is not animated, just a one frame sprite. The collision mask seems fine, don’t see how it would get misaligned because it all works fine on the computer, it’s only on the ipad that the shaking thing happens.

Any chance you can download the project as a zip file and share it?
This will increase the probability we are able to debug this in a matter of days by a lot.

Made a short video of the bug-

Definitely a weird issue if this works on computer. If you can share the project that would be really helpful to find what’s wrong with the preview on iOS


1 Like

Many thanks. I’ve opened the project on the desktop version and no issue here. I’ve saved it as a new cloud project, and opened it on iOS on an iPhone. No issue here too (i’ve enabled again the events to move the character). I’ll try on an iPad.

To be sure, can you try with the very latest iOS version that was released today? Thanks!

Just tried it with the new OS update and it’s still happening. Also tried it on an iPhone and no problems there, but the iPad is still going nuts. Any luck on your iPad?