New update 5.1.157, problem with admob banners

Greetings guys
After the new update the admob banner is multiplied, previously this problem did not occur and I have not changed the code. Any solution?

Hi there, could you share the events you’re using to display the banner?

I can’t reproduce the problem with the admob game example (Admob - a game example from the GDevelop game making app | GDevelop)


Previous configuration, this is how it worked well

I have tried this way and the banner still looks the same as the first image I posted.

Thanks for the screenshots.

I’ve tried exactly the same events on a blank project:

But it seems to work correctly after building for Android:

Do you have other events that are trying to display banners in your app?
I’ll struggle to help more without reproducing the problem unfortunately.
If you could send your projet at, I may take a deeper look.
Or, if you manage to recreate the problem with a really simple project, you could share this one.

Additionally, if you can give more information:

  • Which GDevelop version you use
  • Which phone you’re installing the app on
  • Are you using the built-in Android Build system of GDevelop or building manually?


In order to see the problem you must leave the app open for a few minutes, then the other banners start to appear. I also tested it by creating a new project without other events and the same thing happens.

  • I have the latest version of gdevelop.
  • I have tried it on 4 different devices and the same thing happens.
  • I use the gdevelop build.

Thanks for the info! This helps a lot.
I’m really struggling to reproduce the problem though, even if I wait for several tens of minutes.

The only way I can reproduce a similar problem is if I trigger manually a refresh of the application using a js event doing “window.refresh()”.
Then what happens is that the whole context of the app is destroyed and thus the banner is not removed.
At the next load, admob gets re-initialised and a new banner is added.

I still need more information to be able to help, and the more precise the better.

  • Which devices have you tested exactly?
  • How long does it take for the next banner to appear exactly?
  • Is it possible that this happens at the same time your phone goes into sleep or your screen starts turning off?

Thank you again, this helps finding the cause of the issue.
Once I have more info, I’ll create an issue on Github to track the fix trials.

Hello, thank you for the answers.
Here are some other tests.

tappy test game (android - apk):

Tested on android 10, 11 and 12.
Device characteristics:
Model: Infinix X6812B

Running the game:

I also leave you the link to the test project:

my solution for now was to download the previous version of gdevelop 5.1.156 and it does not have this problem.