Object can't be removed when pasted in another scene (Solved)

I made an oopsie. :sweat:

I was trying to copy and paste some objects from one screen to another.

There’s just a problem. those objects from Scene A were on a layer that Scene B didn’t have. I thought it would just put them on the base layer instead, but it didn’t. they didn’t show up on the workspace.

But when I tested the game, it showed up.

I can’t do anything with it in the workplace. I can’t remove, select it, or anything! it’s not on any of the layers. What do I do?

As far as I know, objects aren’t designed to be copied between scene editors. The bug would be that it let you paste it on a new scene layout at all. I might be misremembering but I don’t think this was ever intended.

If you’re wanting to use an object in multiple scenes, my understanding is that it should be a global object.

the objects I used WERE global, but that still happened. You’re, you’re right I shouldn’t have pasted it from one scene to another. But I still don’t know how to get rid of the unremovable objects.

Two options I’d think to try:

  1. Find the object in the instance list, click it from there, then delete it.
  2. Add a layer that matches the name of the layer it was on in the previous scene. Exit/reload the project afterwards, see if you can edit it then.
1 Like

I did the instance thing, and it worked! thanks a million!